This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 497710 - Firefox/Download/Open Containing folder no longer working by default
Firefox/Download/Open Containing folder no longer working by default
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
: Reopened
: 527290 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-04-26 08:23 EDT by Matthieu Araman
Modified: 2015-03-03 17:40 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 11:30:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mimeTypes.rdf asked Matej (14.95 KB, application/rdf+xml)
2009-06-26 11:08 EDT, Bruno Medeiros
no flags Details
mimeTypes.rdf asked Matej, without changes suggested by Harry Dance (fresh profile) (3.33 KB, application/rdf+xml)
2009-06-26 11:12 EDT, Bruno Medeiros
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 417952 None None None Never

  None (edit)
Description Matthieu Araman 2009-04-26 08:23:57 EDT
Description of problem:
With current rawhide (boot.iso 20090424 just installed), I can no longer, after a donwload launch the file manager, Firefox is asking for a Choose an application, for which I can only say "Heuh!"
 

Version-Release number of selected component (if applicable):
boot.iso 20090424, just installed 20090426

How reproducible:
Always

Steps to Reproduce:
1. Install Rawhide
2. Launch Firefox
3. Download a file (for example, I download rawhide boot.iso file)
4. Wait for download to finish
5. Go to download manager
6. Right click and choose "open containing folder"
  
Actual results:
Firefox open a new window asking to choose a application
and a button to navigate on disk....
This is not user friendly as I have absolutely no idea what to choose.

Expected results:
Firefox should be configured to launch the default file manager (ie gnome file manager in my case)

Additional info:
I think I remember it was working with rawhide in march and it seems something broke it in April.
It's a basic functionality that should be working by default.
Would be great to correct this before shipping...
Comment 1 Matěj Cepl 2009-04-26 11:00:46 EDT
WORKSFORME.
Looks a corrupted ~/.mozilla or some plugin.

Try:

1) firefox -safe-mode
Still a problem?
2) mv ~/.mozilla ~/_mozilla.backup
   firefox
Still a problem?
Comment 2 Matthieu Araman 2009-04-26 17:47:59 EDT
I tried both and it doesn't change anything.
My system is a freshly rawhide installed from today (reformated)
Do you know which setting handle this and which application should be configured ?
Comment 3 Matěj Cepl 2009-04-27 11:35:51 EDT
I think, that application you want is
xdg-open "%s"
Comment 4 Matěj Cepl 2009-04-27 11:38:47 EDT
... and yes happens to me as well (except I get gthumb for all my directory needs) with firefox-3.1-0.11.beta3.fc11.x86_64
Comment 5 Christopher Aillon 2009-05-05 09:50:35 EDT
I think this is upstream as https://bugzilla.mozilla.org/show_bug.cgi?id=417952
Comment 6 Matěj Cepl 2009-05-05 12:47:52 EDT
Right you are. Upstream bug is https://bugzilla.mozilla.org/show_bug.cgi?id=417952 and we believe that it is more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.
Comment 7 Tim Lauridsen 2009-05-11 07:41:43 EDT
The upstream bug is reported against firefox 3 beta in feb. 08
i have updated the upstream bug with information about the issue also exists in current beta releases for firefox 3.5
Comment 8 Jonathan Blandford 2009-05-11 23:57:47 EDT
The upstream bug seems to be about something different.  That one is about highlighting the file in the directory after opening the containing directory with nautilus.  This bug is about bringing up nautilus in the first place.  Seems like we've hijacked the thread a bit.  (Also, I don't think nautilus has easy support for that...)
Comment 9 Ed Avis 2009-05-19 03:14:26 EDT
I also think this is not the same bug as upstream 417952.

However, it is not Fedora-specific.  If you download the official Firefox 3.5b4 binary (I got the en_GB version, and it is built for i386) and start it with a clean ~/.mozilla directory, you still see the same behaviour.
Comment 10 Bug Zapper 2009-06-09 10:36:02 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 han pingtian 2009-06-16 03:11:38 EDT
On my fedora 11 with firefox-3.5-0.20.beta4.fc11.x86_64, this action will open
"Cervisia", a CVS GUI client for me.
Comment 12 Harry Dance 2009-06-22 14:45:09 EDT
For the benefit of anyone encountering this bug, I managed to fix it by clicking "Choose Aplication...", navigating to /usr/bin, and selecting "nautilus", as well as ticking the "Remember my Choice" checkbox.
Comment 13 Matěj Cepl 2009-06-22 18:00:21 EDT
Could I get from anybody whom this issue is still reproducable to attach ~/.mozilla/firefox/*.default/mimeTypes.rdf, please?
Comment 14 Bruno Medeiros 2009-06-26 11:08:41 EDT
Created attachment 349560 [details]
mimeTypes.rdf asked Matej

A have done the association with nautilus suggested by Harry Dance
Comment 15 Bruno Medeiros 2009-06-26 11:12:43 EDT
Created attachment 349562 [details]
mimeTypes.rdf asked Matej, without changes suggested by Harry Dance (fresh profile)
Comment 17 Thomas Janssen 2009-07-05 08:25:55 EDT
I might be late, but it seems there are still people with that problem (in IRC #fedora).I just tried it on my Box and it works with Dolphin out of the box.

firefox-3.5-0.20.beta4.fc11.x86_64

HTH

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Rami Barsoum 2009-07-08 16:17:49 EDT
I am having the same issue on Fedora 11
Choosing Nautilus will not resolve this as it does not offer the option to select the folder location to be used inside Firfox, it simple opens the containing folder under nautilus. Same with the user recommended xdg-open.
This may very well be a Firefox 3.5 beta issue. Please advise with further recommendation.
Comment 19 Garrett Mitchener 2009-07-15 11:02:48 EDT
Maybe related to bug #508585?  or bug #508667?
Comment 20 Jonathan Pritchard 2009-07-28 09:11:04 EDT
I was experiencing this issue but the workaround in Comment #12 fixes the issue.

I am using Fedora 11 with latest updates as of 28/07/09.

Firefox version Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.1) Gecko/20090717 Fedora/3.5.1-1.fc11 Firefox/3.5.1
Comment 21 Christopher Aillon 2009-08-24 21:32:21 EDT
Putting this on the F12Target bug.  Let's make sure this is fixed before F12, and by beta if we can get it.
Comment 22 Christopher Aillon 2009-10-05 17:28:52 EDT
*** Bug 527290 has been marked as a duplicate of this bug. ***
Comment 23 Matěj Cepl 2009-10-05 17:48:10 EDT
Could we ouptut of the command 

grep ^OnlyShowIn /usr/share/applications/gnome-nautilus-folder-handler.desktop

please? If it is just

OnlyShowIn=;

then we have a duplicate of bug 508667 (and bug 508585 could be closed as a duplicate as well).
Comment 24 Matěj Cepl 2009-10-05 17:48:40 EDT
Could we get output of the command 

grep ^OnlyShowIn /usr/share/applications/gnome-nautilus-folder-handler.desktop

please? If it is just

OnlyShowIn=;

then we have a duplicate of bug 508667 (and bug 508585 could be closed as a duplicate as well).
Comment 25 James Livingston 2009-10-05 18:20:12 EDT
Using current F12 packages, I have "OnlyShowIn=GNOME;"
Comment 26 Andrew Jamison 2009-10-05 22:09:31 EDT
f11 running that command outputs 
OnlyShowIn=;
Comment 27 Matěj Cepl 2009-10-06 04:45:49 EDT
(In reply to comment #26)
> f11 running that command outputs 
> OnlyShowIn=;  

So you should leave us here alone with Rawhide and go to bug 508667. We have to find out what's wrong in Rawhide.
Comment 28 Matěj Cepl 2009-10-06 04:46:38 EDT
Not sure whether it is a duplicate of bug 508667, but it is not for me to decide.
Comment 29 Andrew Jamison 2009-10-06 11:57:27 EDT
considering when i reported this bug it was for fedora 11 not rawhide i assumed i was still reporting correctly
Comment 30 Andrew Jamison 2009-10-06 11:58:44 EDT
sorry wrong bug report ignore my last comment 

*/ backs out ashamed
Comment 31 Andrew Jamison 2009-10-06 12:01:31 EDT
seems my bug report was hijacked and turned into a rawhide report and my comments on the original issue wiped hmmmm
Comment 32 Andrew Jamison 2009-10-06 12:02:25 EDT
sorry wrong bug report ignore my last comment 

*/ backs out ashamed
Comment 33 Matthias Clasen 2009-10-26 00:05:24 EDT
Seems to work fine for me ?
Comment 34 Tomáš Bžatek 2009-10-26 11:09:57 EDT
Works fine for me on rawhide, also with clean user profile.

firefox-3.5.3-1.fc12.x86_64
nautilus-2.28.1-1.fc12.x86_64
Comment 35 Julian Sikorski 2009-10-26 11:31:44 EDT
OK, I just checked my rawhide VM and it indeed works (versions the same as specified in comment #34). So, what is broken in F-11?

Note You need to log in before you can comment on or make changes to this bug.