Bug 497725 - gnome-keybinding-properties - Custom shortcuts not working with XF86Audio*
gnome-keybinding-properties - Custom shortcuts not working with XF86Audio*
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-26 10:26 EDT by Roman Rakus
Modified: 2014-01-12 19:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 05:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roman Rakus 2009-04-26 10:26:12 EDT
Description of problem:
My custom shortcuts aren't working with XF86* keys.
When I set it, it's not working. Then I try to set to another key (for example CTRL+U) it works. Then I set it back to XF86* key it works. This is really strange.

Version-Release number of selected component (if applicable):
control-center-2.26.0-5.fc11.i586

How reproducible:


Steps to Reproduce:
1. set shortcut to XF86AudioMute
2. No action
3. set it to CTRL+U
4. it works
5. set it back to XF86AudioMute and it works
  
Actual results:
Works after set to non XF86key

Expected results:
Works directly

Additional info:
Comment 1 Matthias Clasen 2009-04-26 13:52:05 EDT
Not sure what you are doing, but the XF86Audio keys are all bound by default to the correct actions. Why do you think you need to bind them manually ?
Comment 2 Roman Rakus 2009-04-27 02:54:48 EDT
I want to use XF86Audio keys to control volume with `amixer sset ...'
Comment 3 Matthias Clasen 2009-04-27 12:26:12 EDT
Works fine here. I create a custom shortcut, then when I try to assign the mute button to it, it asks me if i want to disable the "Volume Mute" command. If I say yes, then my command assigned to the mute button.

Do the audio buttons work for their original function for you ?
Comment 4 Roman Rakus 2009-04-27 15:33:01 EDT
Original function is ok, but custom not. It's assigned but not working. Any idea how can I track it? Probably is key caught somewhere else.

>...
>say yes, then my command assigned to the mute button.

assigning works for me too, but command is not invoked, when I press the button...
Comment 5 Matthias Clasen 2009-04-28 11:31:05 EDT
Oh, hmm. 

This doesn't seem to work 100% reliably. Just now I've gotten XF86AudioMute to trigger both the mute and the custom command...
Comment 6 Matthias Clasen 2009-04-28 11:41:28 EDT
Filed upstream here: http://bugzilla.gnome.org/show_bug.cgi?id=580616
Comment 7 Roman Rakus 2009-04-28 18:04:25 EDT
Thanks a lot. I will track it there.
Comment 8 Matthias Clasen 2009-04-29 15:54:43 EDT
Should hopefully be fixed in gnome-settings-daemon-2.26.1-3.fc11
Comment 9 Roman Rakus 2009-05-04 05:36:50 EDT
Thanks. Now it is working.

Note You need to log in before you can comment on or make changes to this bug.