Bug 497734 - Cannot generate the binary with qdevelop since qt4.5.1
Cannot generate the binary with qdevelop since qt4.5.1
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qdevelop (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Nicoleau Fabien
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Qt451
  Show dependency treegraph
 
Reported: 2009-04-26 12:46 EDT by hcoohb
Modified: 2009-05-03 13:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.27.4-3.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-02 12:39:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
qdevelop bug (13.12 KB, image/png)
2009-04-26 12:46 EDT, hcoohb
no flags Details
fix (1.07 KB, patch)
2009-04-30 18:15 EDT, Ngo Than
no flags Details | Diff

  None (edit)
Description hcoohb 2009-04-26 12:46:41 EDT
Created attachment 341364 [details]
qdevelop bug

Description of problem:

I think that since the update of qt4.5.1, I can't generate the binary with the qdevelop button, or with F7.
As soon as I open a project or create a new one, the icon for compiling are disabled and the one for stopping the compilation is enabled but have no effect.
I have fedora10 with the kde-redhat-testing repository enabled.
I also tried new version on Koji (fc10, fc11, fc12) but the same problem appeared on all.
I also tried to empty ~/.qdevelop, but no effect...

Version-Release number of selected component (if applicable):
0.27.4

How reproducible:
always

Steps to Reproduce:
1. open qdevelop
2. create a new project or open an existing one
  
Actual results:
Compilation impossible (see the attachment) and clicking on the stop icon have no effect

Expected results:
The stop icon disabled and the compilation icon enabled

Additional info:
Comment 1 Nicoleau Fabien 2009-04-26 15:15:43 EDT
I can't reproduce the bug as actual version in Fedora repositories is 4.5.0.

If you launch qdevelop in a console, do you have more informations ?
If you rebuild qdevelop under *your* Qt version (rawhide also provides 4.5.0), does it work ?
Comment 2 hcoohb 2009-04-27 09:39:31 EDT
Hello,

I have no message at all when I launch qdevelop in a console.
And I am not very familiar with building programs,
But maybe if you can give me steps I have to follow, I can give it a try !
Comment 3 Nicoleau Fabien 2009-04-30 12:01:46 EDT
You are using a testing version .... not an official one...
To build, just donwload qdevelop sources, and read compilation step :
qmake-qt4
make

The binary will be stored in <sources>/bin

Just launch it an try to reproduce the bug.
Comment 4 Ngo Than 2009-04-30 18:15:49 EDT
Created attachment 342017 [details]
fix

fix the issue with qt >= 4.5.1
Comment 5 Kevin Kofler 2009-04-30 18:34:46 EDT
Should be fixed in 0.27.4-3.fc{9,10,11,12}, now building.
Comment 6 Kevin Kofler 2009-04-30 18:57:12 EDT
dist-f11 tagging requested: https://fedorahosted.org/rel-eng/ticket/1704
Comment 7 Fedora Update System 2009-04-30 19:03:59 EDT
qdevelop-0.27.4-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/qdevelop-0.27.4-3.fc10
Comment 8 Fedora Update System 2009-04-30 19:04:23 EDT
qdevelop-0.27.4-3.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/qdevelop-0.27.4-3.fc9
Comment 9 Fedora Update System 2009-05-02 12:28:14 EDT
qdevelop-0.27.4-3.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-05-02 12:39:54 EDT
qdevelop-0.27.4-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 hcoohb 2009-05-03 13:29:46 EDT
I can confirm that the bug has been fixed for me with the update !
Thank you !

Note You need to log in before you can comment on or make changes to this bug.