Bug 497743 - gnome-power-manager sleeps after waking
gnome-power-manager sleeps after waking
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 507547 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-26 15:25 EDT by Matthew Garrett
Modified: 2013-01-10 02:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 08:34:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround patch (648 bytes, patch)
2009-04-26 15:39 EDT, Matthew Garrett
no flags Details | Diff

  None (edit)
Description Matthew Garrett 2009-04-26 15:25:56 EDT
Hitting the sleep button causes g-p-m to initiate sleep. It's blocked while doing so. This means that the hal button press event isn't delivered until after resume, which means too much time has passed for them to be flagged as duplicate events. This causes a further sleep cycle.
Comment 1 Matthew Garrett 2009-04-26 15:39:26 EDT
Created attachment 341367 [details]
Workaround patch

This patch simply skips sending the hal event if it's a button event rather than a lid event. Probably not suitable for upstream, but potentially a decent workaround for F-11? Tested with no double suspends and suspend on lid close still working.
Comment 2 Bug Zapper 2009-06-09 10:37:09 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michal Schmidt 2009-06-25 07:28:40 EDT
*** Bug 507547 has been marked as a duplicate of this bug. ***
Comment 4 Michal Schmidt 2009-06-25 07:30:26 EDT
The patch has been successfully tested by the two reporters of bug 507547. Please consider releasing an update with it.
Comment 5 Will Kemp 2009-07-20 16:36:46 EDT
I got rid of this problem by installing the patched gnome power manager (linked to in bug 507547). But it's come back again with the latest update.
Comment 6 Jan Drábek 2009-07-21 02:59:54 EDT
I am facing same problem after latest update.
Comment 7 Richard Hughes 2009-08-20 08:34:07 EDT
Ooops.

* Mon Aug 20 2009 Richard Hughes  <rhughes@redhat.com> - 2.26.4-3
- Actually apply the patch in #497743

See http://koji.fedoraproject.org/koji/taskinfo?taskID=1617346 for the build.

Note You need to log in before you can comment on or make changes to this bug.