Bug 497775 - nautilus-sendto doesn't provides thunderbird entry, mail agent still remains Evolution
nautilus-sendto doesn't provides thunderbird entry, mail agent still remains ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus-sendto (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 03:44 EDT by Axel
Modified: 2009-04-27 09:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 09:23:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel 2009-04-27 03:44:50 EDT
Description of problem:
When defining Thunderbird as the default mail agent (from the gnome control center), nautilus-sendto doesn't provides a thunderbird entry in the menu. It still remains to Evolution as the mail agent. Switching back to evolution then back to thunderbird doesn't work either.


Version-Release number of selected component (if applicable):
nautilus-sendto-1.1.4.1-1.fc11.i586
nautilus-2.26.2-2.fc11.i586
evolution-2.26.1-2.fc11.i586
thunderbird-3.0-2.1.beta2.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Install thunderbird and nautilus-sendto
2. Open a nautilus window
3. Right click on a file, select "Send to" item

  
Actual results:
No "thunderbird" item is displayed in the menu. An Evolution item is still available.

Expected results:
Evolution item is replaced by thunderbird item.

Additional info:
Comment 1 Axel 2009-04-27 04:12:01 EDT
From the command line, nautilus-sendto launched twice : 

[axel@axel-asus ~]$ nautilus-sendto ~/foo 
Init removable-devices plugin
Init empathy plugin
** (nautilus-sendto:2611): DEBUG: check_for_accounts: No enabled accounts
Init pidgin plugin
Init evolution plugin
Init nautilus burn plugin

[axel@axel-asus ~]$ nautilus-sendto ~/foo 
Init removable-devices plugin
Init empathy plugin
** (nautilus-sendto:2617): DEBUG: check_for_accounts: No enabled accounts
Init pidgin plugin
Init evolution plugin
Init nautilus burn plugin
Comment 2 Axel 2009-04-27 04:12:44 EDT
2 imap accounts are set up in thunderbird.
Comment 3 Bastien Nocera 2009-04-27 04:56:15 EDT
(In reply to comment #0)
> Description of problem:
> When defining Thunderbird as the default mail agent (from the gnome control
> center), nautilus-sendto doesn't provides a thunderbird entry in the menu. It
> still remains to Evolution as the mail agent. Switching back to evolution then
> back to thunderbird doesn't work either.

nautilus-sendto won't show a separate entry for each installed e-mail client.

Care to explain what "doesn't work"?
Comment 4 Axel 2009-04-27 05:04:46 EDT
I first thought as a mis-defined preference, so I tried to set it again to thunderbird. The entry just remains as "Mail (Evolution)". Using this entry opens evolution.
Comment 5 Bastien Nocera 2009-04-27 05:12:33 EDT
What's the output of:
cat ~/.local/share/applications/preferred-mail-reader.desktop
and
gconftool-2 -g /desktop/gnome/url-handlers/mailto/command
Comment 6 Axel 2009-04-27 05:23:43 EDT
[axel@axel-asus ~]$ cat ~/.local/share/applications/preferred-mail-reader.desktop

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=Thunderbird Email
GenericName=Email
Comment=Send and Receive Email
Exec=thunderbird
Icon=thunderbird
Terminal=false
Type=Application
StartupWMClass=Thunderbird-bin
X-Desktop-File-Install-Version=0.15
Categories=Email;Network;
X-Panel-Monitor=true
NoDisplay=true

[axel@axel-asus ~]$ gconftool-2 -g /desktop/gnome/url-handlers/mailto/command
thunderbird %s
Comment 7 Axel 2009-04-27 05:28:27 EDT
I don't know if it's related, but I first used evolution, then I switched to thunderbird. Evolution mail accounts have been deleted though.
Comment 8 Bastien Nocera 2009-04-27 05:49:51 EDT
It works fine here:

$ nautilus-sendto Makefile
Init nautilus burn plugin
Init removable-devices plugin
Init evolution plugin
Init pidgin plugin

** Message: Mailer type: 4
** Message: Command: thunderbird -compose to="Sébastien Aime <saime@redhat.com>",attachment='file:///home/hadess/Projects/Cvs/nautilus-sendto/src/Makefile'

What's the full output of nautilus-sendto when you reproduce the problem? Or are you still under the impression that the "Evolution" entry won't open Thunderbird?
Comment 9 Axel 2009-04-27 05:59:16 EDT
[axel@axel-asus ~]$ nautilus-sendto ~/foo 
Init removable-devices plugin
Init empathy plugin
** (nautilus-sendto:4066): DEBUG: check_for_accounts: No enabled accounts
Init pidgin plugin
Init evolution plugin
Init nautilus burn plugin
** Message: Mailer type: 4
** Message: Command: thunderbird -compose to="axel.azerty@laposte.net",attachment='file:///home/axel/foo'

Indeed, a thunderbird mail composing window is opened.
The last time I launched it, evolution started (the evolution first run wizard in fact, since no accounts where defined)

I feel a bit like someone who reports a bug which isn't one :(
Anyway the label of the entry menu is "Mail (Evolution)".
Really sorry for the time loss.
Comment 10 Bastien Nocera 2009-04-27 09:23:44 EDT
I've removed the "(Evolution)" bit of the string in the upstream plugin. It will be in the next release of nautilus-sendto, and make it into rawhide shortly.

This should clear the confusion...

Note You need to log in before you can comment on or make changes to this bug.