Bug 497798 - xdmcp login to gdm gives warning box
xdmcp login to gdm gives warning box
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 05:59 EDT by Michael Young
Modified: 2015-01-14 18:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 11:49:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2009-04-27 05:59:39 EDT
When I connect to gdm via an XDMCP connection, I get a warning dialogue box containing

There is a problem with the configuration server.
(/usr/libexec/gconf-sanity-check-2 exited with status 256)

before the gdm login screen comes up and again after putting in a correct username and password before the desktop is populated. Running /usr/libexec/gconf-sanity-check-2 by hand after the desktop has appeared gives no error and return code 0, so I suspect the error is related to the gdm username.
If I just connect and don't click the "Close" button then I get the following error in /var/log/gdm/127.0.0.1:1-greeter.log which might be related.

The files that contain your preference settings are currently in use.

You might be logged in to a session from another computer, and the other login session is using your preference settings files.

You can continue to use the current session, but this might cause temporary problems with the preference settings in the other session.

Do you want to continue? Continue (y/n)?gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server 127.0.0.1:1.0.
Comment 1 Michael Young 2009-04-29 11:49:54 EDT
It turns out this was a local configuration issue. I had told gconf to look for a local configuration directory via an entry in /etc/gconf/2/local-defaults.path but not created or populated that directory. If the directory exists, even if it is empty, then the error goes away.

Note You need to log in before you can comment on or make changes to this bug.