Bug 497858 - Unable to automount an attached CD under RHEL5.3 i686, running as a VM under RHEV
Unable to automount an attached CD under RHEL5.3 i686, running as a VM under ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.3
i686 Linux
low Severity low
: rc
: ---
Assigned To: Tim Burke
VDI
: Improvement, Reopened
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-04-27 11:30 EDT by Dan Yasny
Modified: 2013-07-02 03:07 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 10:40:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal and lshal -m outputs (37.24 KB, text/plain)
2010-02-03 08:05 EST, Dan Yasny
no flags Details
lshal output from an F12 VM (50.98 KB, text/plain)
2010-02-04 11:05 EST, Dan Yasny
no flags Details

  None (edit)
Description Dan Yasny 2009-04-27 11:30:36 EDT
Description of problem:
Unable to automount an attached CD under RHEL5.3 i686, running as a VM under RHEV

Version-Release number of selected component (if applicable):
2.6.18-128.el5 #1 SMP Wed Dec 17 11:42:39 EST 2008 i686 athlon i386 GNU/Linux


How reproducible:
Try to attach a CD ISO(9660) file to a RHEL5.3 VM.


Steps to Reproduce:
1. Install RHEL5.3 i386 as a VM under RHEV
2. log in to GNOME as user or root
3. attach a CD image to the VM
  
Actual results:
1. dmesg shows: cdrom: This disc does not have any tracks I recognize
2. manual `mount /dev/cdrom /mnt` works OK
3. 
# file -s /dev/cdrom
/dev/cdrom: symbolic link to `hdc'
# file -s /dev/hdc
/dev/hdc: ISO 9660 CD-ROM filesystem data 'RHEL/5.3 i386 DVD   ' (bootable)
#CD is recognised, but not under GNOME

Expected results:
CD should automount as inserted, and show up on the GNOME desktop

Additional info:
tested with 2.6.18-92, 2.6.18-128, 2.6.18-140 - issue persists
Fedora 10 VM on the same config - no problem
Compiled a vanilla 2.6.29.1 kernel under RHEL5.3 - everything works fine, no problem
Comment 3 Yaniv Kaul 2010-01-20 04:31:07 EST
Also seen on 5.4/64b (2.6.18-164.10.1.el5).
Comment 5 Dan Yasny 2010-02-03 04:20:47 EST
Bug reopened - this is still an issue with RHEV
Comment 6 Bryn M. Reeves 2010-02-03 06:56:40 EST
Looks like the drive is either not exposing properties that HAL etc. expect to identify it as a CD drive or is not issuing events on media insertion. Would help to have lsmod output to know what modules are loaded.

Istr there's some magic words that'll make HAL log verbosely (desktop folks would know) and that might reveal some more but in the meantime lshal probably isn't a bad place to begin.
Comment 7 Bryn M. Reeves 2010-02-03 07:03:51 EST
As Olivier mentioned  on irc, I was thinking of dbus-monitor in the previous comment. This should give some idea what events the desktop is seeing (although the fact it doesn't show up on the desktop as a CD drive makes me suspect that it's an attributes problem).
Comment 8 Dan Yasny 2010-02-03 07:10:38 EST
 tried it with lshal -m - there's nothing when I attach a CD image. when I change it, I see that the removal of the 1st image is detected, but not the attachment of the second one
Comment 9 Dan Yasny 2010-02-03 08:05:41 EST
Created attachment 388521 [details]
lshal and lshal -m outputs

lshal -m was taken during these steps:
1. attach CD image (no output)
2. attach another CD image (output for detaching the 1st image, no output for attaching the 2nd)
Comment 11 Dan Yasny 2010-02-04 11:05:54 EST
Created attachment 388822 [details]
lshal output from an F12 VM
Comment 15 RHEL Product and Program Management 2011-01-11 15:48:10 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 16 RHEL Product and Program Management 2011-01-11 17:45:56 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.