Bug 497921 - Xine with xv sometimes hangs X
Xine with xv sometimes hangs X
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 16:50 EDT by Mace Moneta
Modified: 2013-04-02 00:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 01:24:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (26.20 KB, text/plain)
2009-04-28 19:27 EDT, Mace Moneta
no flags Details
xorg.conf (2.35 KB, text/plain)
2009-04-28 19:27 EDT, Mace Moneta
no flags Details

  None (edit)
Description Mace Moneta 2009-04-27 16:50:43 EDT
Description of problem:

When running xine with xv, Xorg will sometimes hang immediately.  It seems to be about a 50% probability.  I can run it two or three times no problem, then have the problem three times in row.  There are no error in dmesg, /var/log/messages or Xorg.0.log.

When it hangs, killing -9 Xorg does not recover X.  I've also tried a 'vbetool post' before killing Xorg.  While that displays some POST information on the screen, Xorg is still unable to start.  A system reboot is the only method that seems to work.

I tried running the newly available intel_gpu_top immediately after the hang:

                  task  percent busy

                   Row 0, EU 1: 100
                   Row 0, EU 2: 100
                   Row 0, EU 3: 100
                   Row 1, EU 0: 100
                   Row 1, EU 1: 100
                   Row 1, EU 2: 100
                   Row 1, EU 3: 100
                  Setup Engine: 100
                    Windowizer: 100

The intel_gpu_top reported the same after the 'vbetool post' and restarting Xorg.

Unfortunately, intel_gpu_dump (assuming useful information might be obtained with it) was unusable (Bug 497918).

Version-Release number of selected component (if applicable):

xorg-x11-drv-intel-2.7.0-2.fc11.x86_64

How reproducible:

About half the time

Steps to Reproduce:
1.xine some-video
2.
3.
  
Actual results:

Either normal operation, or an unrecoverable Xorg hang.

Expected results:

Normal video playback

Additional info: Intel G45/X4500HD, kernel-2.6.29.1-102.fc11.x86_64
Comment 1 Mace Moneta 2009-04-27 16:51:41 EDT
I just wanted to note that mplayer with xv does not cause this problem.
Comment 2 Matěj Cepl 2009-04-28 12:44:40 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available) and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf (if you have one) whatsoever and let X11 autodetect your display and video card? Attach to this bug /var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Mace Moneta 2009-04-28 19:27:02 EDT
Created attachment 341670 [details]
Xorg.0.log

The Xorg.0.log

The system is using EXA and nomodeset.  I can't run with KMS+UXA because of bug 496516.
Comment 5 Mace Moneta 2009-04-28 19:27:49 EDT
Created attachment 341671 [details]
xorg.conf
Comment 6 Bug Zapper 2009-06-09 10:40:24 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Matěj Cepl 2009-11-05 13:27:39 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 9 Mace Moneta 2009-11-30 01:24:59 EST
I'm no longer seeing this after upgrading to F12.  Closing.

Note You need to log in before you can comment on or make changes to this bug.