Bug 497937 - Low volume on ThinkPad T61 [HDA Intel 17aa:20ac]
Low volume on ThinkPad T61 [HDA Intel 17aa:20ac]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-04-27 20:25 EDT by Charles R. Anderson
Modified: 2009-05-14 16:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-14 16:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info.txt (23.52 KB, text/plain)
2009-04-27 20:25 EDT, Charles R. Anderson
no flags Details
amixer_diff.txt (828 bytes, text/plain)
2009-04-27 20:27 EDT, Charles R. Anderson
no flags Details
amixer_before.txt (3.48 KB, text/plain)
2009-04-27 23:46 EDT, Charles R. Anderson
no flags Details
amixer_after.txt (3.48 KB, text/plain)
2009-04-27 23:47 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2009-04-27 20:25:29 EDT
Created attachment 341495 [details]
alsa-info.txt

Description of problem:

I'm filing this bug report per the "Volume not correctly controlled by new gnome-volume-control bugs: please report" email from Adam Williamson.  On my Lenovo ThinkPad T61, using the internal speakers, the volume is very low until I run alsamixer -c0 and raise the PCM slider.  I tested with F11-Preview LiveCD i686.

Version-Release number of selected component (if applicable):
kernel-2.6.29.1-102.fc11.i586
alsa-lib-1.0.19-3.fc11.i586
pulseaudio-0.9.15-11.fc11.i586
gnome-media-2.26.0-2.fc11.i586

How reproducible:
always

Steps to Reproduce:
1. alsa-info.sh --no-upload
2. alsactl init
3. amixer -c0 > amixer_before.txt
4. play music, note low volume even with gnome-volume-control at maximum
5. alsamixer -c0, raise PCM slider to 100%
6. now music is loud enough and can be adequately lowered using gnome-volume-control.  multimedia keys volume up/down/mute all work correctly.
7. amixer -c0 > amixer_after.txt
8. diff -u amixer_before.txt amixer_after.txt > amixer_diff.txt
  
Actual results:

[root@localhost ~]# alsa-info.sh --no-upload
WARNING: Deprecated config file /etc/modprobe.conf, all config files 
belong into /etc/modprobe.d/.
ALSA Information Script v 0.4.54
--------------------------------

This script will collect information about your ALSA installation and 
sound related hardware, to help diagnose your problem.

Do you want to run this script? [y/n] : y
										
Could not automatically upload output to http://www.alsa-project.org
Possible reasons are:
    1. Couldnt find 'wget' in your PATH
    2. Your version of wget is less than 1.8.2

Please manually upload /tmp/alsa-info.txt to 
http://www.alsa-project.org/cardinfo-db/ and submit your post.

[root@localhost tmp]# alsactl init
Unknown hardware: "HDA-Intel" "Analog Devices AD1984" 
"HDA:11d41984,17aa20bb,00100400" "" ""
Hardware is initialized using a guess method
[root@localhost tmp]# amixer -c0 > amixer_before.txt
[root@localhost tmp]# alsamixer -c0

[root@localhost tmp]# amixer -c0 > amixer_after.txt
[root@localhost tmp]# diff -ub amixer_before.txt amixer_after.txt 

Expected results:

PCM volume should be initialized properly by default so that the alsamixer -c0 step is unnecessary.

Additional info:
Comment 1 Charles R. Anderson 2009-04-27 20:27:11 EDT
Created attachment 341496 [details]
amixer_diff.txt
Comment 2 Charles R. Anderson 2009-04-27 20:35:10 EDT
I repeated the test with speakers attached, and the result is the same.  When using powered speakers, the problem is less pronounced, because the volume happens to be "loud enough" with the default PCM volume of 64% and the powered speaker volume turned all the way up.
Comment 3 Adam Williamson 2009-04-27 20:39:54 EDT
Thanks for the full report: triaged.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-04-27 23:03:24 EDT
I just realized the diff may not have enough context: please also provide the amixer_before.txt and amixer_after.txt files themselves. sorry, my fault! thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Charles R. Anderson 2009-04-27 23:46:43 EDT
Created attachment 341507 [details]
amixer_before.txt
Comment 6 Charles R. Anderson 2009-04-27 23:47:22 EDT
Created attachment 341508 [details]
amixer_after.txt
Comment 7 Lennart Poettering 2009-04-30 15:57:27 EDT
I guess this should be added to the ALSA db. Reassigning.
Comment 8 Jaroslav Kysela 2009-05-13 04:11:17 EDT
Please, retest witl alsa-utils-1.0.20.
Comment 9 Dave Maley 2009-05-13 15:01:04 EDT
I'm not the original reporter however alsa-utils-1.0.20 does appear to resolve the issue on my T61.  I should note that I had to run 'alsactl init' manually in order to hear any difference.
Comment 10 Adam Williamson 2009-05-14 14:55:46 EDT
dave: does it then survive subsequent reboots? If so, that's normal - changes to the defaults don't get automatically applied on alsa-utils updates, because the system just stores the current levels at each shut down and restores them at each boot. So it's normal that you have to run 'alsactl init' to force a reset to defaults one time.
Comment 11 Dave Maley 2009-05-14 15:34:53 EDT
Adam - yes it survives reboots just fine.  I just wanted to note the alsactl piece for the benefit of anybody else testing to validate the fix.
Comment 12 Adam Williamson 2009-05-14 16:10:33 EDT
OK, so we can mark this as fixed, thanks for the feedback...but, Jaroslav, as I said by email, it'd really be nice for us to try and get this overridden into GA, so people will benefit from the fixes without having to do anything manually.

Note You need to log in before you can comment on or make changes to this bug.