Bug 497939 - [RHEL5] Affected_cpus Not Working for AMD Quad-Core Systems
[RHEL5] Affected_cpus Not Working for AMD Quad-Core Systems
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
high Severity high
: rc
: ---
Assigned To: John Feeney
Red Hat Kernel QE team
:
Depends On: 497938
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 20:36 EDT by CAI Qian
Modified: 2013-01-10 02:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 497938
Environment:
Last Closed: 2009-04-29 13:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2009-04-27 20:36:56 EDT
+++ This bug was initially created as a clone of Bug #497938 +++ Jarod Wilson found that it never work for those systems even with upstream kernels, so I guess it is not working for RHEL5 as well. Please correct me if I am wrong.

Description of problem:
An AMD machine has 4 cores, but the affected_cpus file has only one.

# cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 2
model name      : Quad-Core AMD Opteron(tm) Processor 8356
stepping        : 3
cpu MHz         : 1400.000
cache size      : 512 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 4
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov
pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt
pdpe1gb
rdtscp lm 3dnowext 3dnow pni monitor cx16 popcnt lahf_lm cmp_legacy svm
extapic
cr8_legacy altmovcr8 abm sse4a misalignsse 3dnowprefetch osvw
bogomips        : 4598.26
TLB size        : 1104 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate <NULL>   <-- strange NULL here.
...

# cat /sys/devices/system/cpu/cpu*/cpufreq/affected_cpus
0
10
11
12
13
14
15
16
17
18
19
1
20
21
22
23
24
25
26
27
28
29
2
30
31
3
4
5
6
7
8
9

# lsmod
...
powernow_k8            22753  1
...

# uname -ra
Linux sun-x4600m2-01.rhts.bos.redhat.com 2.6.9-88.ELlargesmp #1 SMP Mon Apr 13
19:33:40 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

sun-x4600m2-01.rhts.bos.redhat.com was working before until it has upgraded
from Dual-Core to Quad-Core CPUs. More details about how it was tested before,
please see,
https://bugzilla.redhat.com/show_bug.cgi?id=469647#c7

It looks like affected_cpus never work on AMD Quad-Core systems that I have
tested another two machines without luck.

amd-ma78gm-01.rhts.bos.redhat.com
model name      : AMD Phenom(tm) 9750 Quad-Core Processor

hp-xw9400-01.rhts.bos.redhat.com
model name      : Quad-Core AMD Opteron(tm) Processor 2382

Intel Quad-Core system is working without problem.

# uname -ra
Linux ibm-defiant.rhts.bos.redhat.com 2.6.9-89.ELsmp #1 SMP Mon Apr 20 10:33:05
EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

#  cat /sys/devices/system/cpu/*/cpufreq/affected_cpus
0 1 2 3
0 1 2 3
0 1 2 3
0 1 2 3

# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model  : 15
model name : Intel(R) Xeon(R) CPU           X5355  @ 2.66GHz
stepping : 7
cpu MHz  : 2331.000
cache size : 4096 KB
physical id : 0
siblings : 4
core id  : 0
cpu cores : 4
fpu  : yes
fpu_exception : yes
cpuid level : 10
wp  : yes
flags  : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm pni monitor
ds_cpl est tm2 cx16 xtpr lahf_lm
bogomips : 5323.70
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:
...

   ------- Comment #19 From Jarod Wilson (jwilson@redhat.com) 2009-04-27 11:15:49 EDT -------
(In reply to comment #17)
> It looks like affected_cpus never work on AMD Quad-Core systems that I have
> tested another two machines without luck.
>
> amd-ma78gm-01.rhts.bos.redhat.com
> model name      : AMD Phenom(tm) 9750 Quad-Core Processor
>
> hp-xw9400-01.rhts.bos.redhat.com
> model name      : Quad-Core AMD Opteron(tm) Processor 2382

Hrm... Just looked at a quad-core amd box here which is running Fedora 10
(2.6.27.21-based kernel). affected_cpus for each core doesn't list anything but
itself there either...


Version-Release number of selected component (if applicable):
kernel-2.6.9-89.EL

How reproducible:
always

Steps to Reproduce:
1. look at /sys/devices/system/cpu/*/cpufreq/affected_cpus
  
Actual results:
List only one CPU core.

Expected results:
Should list 4 CPU cores in the same physical processor.

Additional info:
Dmesg and cpuinfo files on the system can be found at,

https://bugzilla.redhat.com/show_bug.cgi?id=465366#c15
https://bugzilla.redhat.com/show_bug.cgi?id=465366#c14
Comment 1 CAI Qian 2009-04-29 13:22:36 EDT
Comment #4 From  Bhavna Sarathy (bhavna.sarathy@amd.com)  2009-04-28 10:11:53 EDT   (-) [reply] -------      Private

Affected_cpu's is defined as all the CPUs that are changed when any CPU in 
that group is changed. Greyhound cores have independent frequency control,
so each core should have its own number and not effect any other cores.

Not a bug.

Note You need to log in before you can comment on or make changes to this bug.