Bug 497945 - PA needs to merge Master/PCM into a single slider
PA needs to merge Master/PCM into a single slider
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-27 22:35 EDT by Bruno Wolff III
Modified: 2009-06-29 07:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-29 07:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa info (18.61 KB, text/plain)
2009-04-27 22:35 EDT, Bruno Wolff III
no flags Details
amixer_before.txt (4.77 KB, text/plain)
2009-04-27 23:53 EDT, Bruno Wolff III
no flags Details
amixer_after.txt (4.77 KB, text/plain)
2009-04-27 23:57 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2009-04-27 22:35:39 EDT
Created attachment 341503 [details]
alsa info

Description of problem:
As requested by Adam I am filing this because I needed to run alsamixer in order to get a loud enough volume level on one of my machines.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.15-11.fc11.i586

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
This is with a pair of small unamped speakers sitting on my desk. Before fixing things the maximum volume is audible but too quiet. After raising the PCM level to the max I have some head room with the master volume and don't need to increase it all of the way up to get a comfortable level.

Expected results:


Additional info:
--- amixer_before.txt	2009-04-27 21:26:01.000000000 -0500
+++ amixer_after.txt	2009-04-27 21:31:42.000000000 -0500
@@ -3,8 +3,8 @@
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
-  Front Left: Playback 17 [55%] [-21.00dB] [on]
-  Front Right: Playback 17 [55%] [-21.00dB] [on]
+  Front Left: Playback 25 [81%] [-9.00dB] [on]
+  Front Right: Playback 25 [81%] [-9.00dB] [on]
 Simple mixer control 'Master Mono',0
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
   Playback channels: Mono
@@ -38,8 +38,8 @@
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
-  Front Left: Playback 23 [74%] [0.00dB] [on]
-  Front Right: Playback 23 [74%] [0.00dB] [on]
+  Front Left: Playback 31 [100%] [12.00dB] [on]
+  Front Right: Playback 31 [100%] [12.00dB] [on]
 Simple mixer control 'Line',0
   Capabilities: pvolume pswitch pswitch-joined cswitch cswitch-exclusive
   Capture exclusive group: 0
Comment 1 Adam Williamson 2009-04-27 23:02:28 EDT
hmm, I just noticed the diffs might not have enough context. can you also attached the amixer_before.txt and amixer_after.txt? sorry, my fault. thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bruno Wolff III 2009-04-27 23:53:16 EDT
Created attachment 341509 [details]
amixer_before.txt
Comment 3 Bruno Wolff III 2009-04-27 23:57:58 EDT
Created attachment 341510 [details]
amixer_after.txt

I still had the files hanging around, so it was easy to provide them.

I think I might have implied I have more volume headroom after the change than I really do. After raising PCM to max, I usually have master close to or at max, depending on what I am playing.

One other odd thing was in your message you mention gnome-volume-control, but I don't see that available. I use pulseaudio volume control or the volume control in the app. gnome-volume-control went away sometime during rawhide. I used to see weird messages related to it when switching between F10 and F11 using the same /home .
Comment 4 Adam Williamson 2009-04-28 01:44:02 EDT
gnome-volume-control is provided by gnome-media in Rawhide. It's included in a default install. do you have that package installed?

if the volume even with all sliders in alsamixer or gnome-alsamixer at max is still fairly low (if you can compare with Windows that'd be great), that's also a bug, but a different one; we'd need a separate report for that.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Bruno Wolff III 2009-04-28 09:39:24 EDT
I have gnome-media installed. I can run gnome-volume-control directly. For some reason I can find menu for it so I can put it back on my panel. It got messed up in a relatively early F11 rawhide and I started using the pulse audio volume control instead. On some machines I have done fresh installs on (very recently), the normal gnome volume control is there, so I just need to look harder.

I think the maximum sound output level is reasonable considering that the speakers are being driven entirely by the sound card without their own amps.
But I don't know enough about sound devices to be completely sure of that opinion.
Comment 6 Bruno Wolff III 2009-04-28 09:43:13 EDT
This machine has never had windows on it. I built it from parts.
Comment 7 Adam Williamson 2009-04-28 19:58:50 EDT
If these are truly passive speakers (which is very unusual for computer speakers), then it would be normal for the maximum available volume to be very quiet, yes. The minimal level of amplification that most sound cards are capable of is nowhere near enough to drive speakers to any high level of volume.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Bruno Wolff III 2009-04-28 23:22:06 EDT
They have no power source other than the sound card output. They were scrounged from a system I bought around 1995.
Comment 9 Adam Williamson 2009-04-29 00:14:33 EDT
Ah, OK. Then yes, quietness is to be expected :)

actually...can you test with a pair of earphones or headphones, and see whether you get comfortable volume out of those with just the Pulse volume control? I'm not sure a pair of 1995 vintage passive speakers is a great test...

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Bruno Wolff III 2009-04-29 10:26:34 EDT
I only did a quick test with the headphones because I am getting some crashes that appear to be correlated with sound playing and load. (That's another ticket that I owe a crash dump for, but the crash dump feature doesn't play well with encrypted root, so it's been taking more time than I had hoped.)
Anyway, after running alsactl init and having the volume at or near max (the system crashed before I could double check settings) the headphones were at a comfortable level. So while they are usable (where as the speakers wouldn't have been), again there's not a lot of headroom.
Comment 11 Adam Williamson 2009-04-29 11:36:57 EDT
OK, so basically what I needed to know is that increasing the default setting of the second channel won't make things painfully loud in a more 'normal' setup than a pair of very old speakers. Which seems to be true, so we could go ahead and change the default for the second channel. thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Lennart Poettering 2009-04-30 16:03:23 EDT
Hmm, I don't think the ALSA db should cater for particular un-amped speakers.

I think it is better to handle this inside of PA, i.e. by merging 'PCM' and 'Master' into a single slider, as I have been planning.

I am now renaming this bug, to keep track of the PCM/Master merging logic. This will be stuff for F12
Comment 13 Bruno Wolff III 2009-04-30 16:22:03 EDT
That sounds fine to me. For what I do, only the combined value makes a difference.
Comment 14 Adam Williamson 2009-04-30 19:32:11 EDT
lennart: "Hmm, I don't think the ALSA db should cater for particular un-amped speakers."

that's why I asked him to do the headphone test. But yeah, the results of that are borderline, it probably doesn't make sense to make a change to the DB based solely on this data.
Comment 15 Bug Zapper 2009-06-09 10:41:25 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Lennart Poettering 2009-06-29 07:12:28 EDT
The PA version in Rawhide now merges PCM/Master

Note You need to log in before you can comment on or make changes to this bug.