Bug 497946 - ibus-daemon should not fail silently
ibus-daemon should not fail silently
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: imsettings (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-04-27 22:44 EDT by Warren Togami
Modified: 2009-10-08 08:24 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-08 08:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-27 22:44:20 EDT
ibus-1.1.0.20090423-1.fc11

Currently ibus-daemon can fail to startup under certain circumstances like socket directory owned by another user.  It currently fails silently, so the user has no idea why it failed.

ibus-daemon should pop-up and tell the user it failed to start, and why.

ibus-daemon should probably run:
ibus-x11 --fail "fail message here"
Comment 1 Peng Huang 2009-05-08 02:35:59 EDT
What's kind of message should be show to uers? need detail of fail reason?

I have another suggestion, let im-settings to show the error messages to user. It will benefit scim and other im too.
Comment 2 Akira TAGOH 2009-05-08 04:37:08 EDT
Well, imsettings is capable to catch up the fail but in this case it won't grabs so that it happens later. imsettings needs to watch the child status during it's alive then. aside from that, there are no clients to display the error so far since applet isn't running by default. I'm not quite sure if contacting to notification-daemon directly from the dbus service is the right design.

Anyway, in either cases, what it can says is, "Input Method died unexpectedly. I don't know why. the error code was blahblahblah. over." we may need any way to know the detailed human-readable reason for usability.
Comment 3 Peng Huang 2009-05-25 05:15:07 EDT
(In reply to comment #2)
> Well, imsettings is capable to catch up the fail but in this case it won't
> grabs so that it happens later. imsettings needs to watch the child status
> during it's alive then. aside from that, there are no clients to display the
> error so far since applet isn't running by default. I'm not quite sure if
> contacting to notification-daemon directly from the dbus service is the right
> design.
> 
> Anyway, in either cases, what it can says is, "Input Method died unexpectedly.
> I don't know why. the error code was blahblahblah. over." we may need any way
> to know the detailed human-readable reason for usability.  

I think imsetting could log input method's error output in a file, and ask user to check it.
Comment 4 Bug Zapper 2009-06-09 10:41:32 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Akira TAGOH 2009-08-20 06:21:57 EDT
Fixed in imsettings-0.107.1-2.fc12.

Note You need to log in before you can comment on or make changes to this bug.