Bug 497971 - [ne_NP] libX11 does not support locale ne_NP.UTF-8
[ne_NP] libX11 does not support locale ne_NP.UTF-8
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
11
All Linux
high Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: i18n, Patch
Depends On: 502433
Blocks: 497038
  Show dependency treegraph
 
Reported: 2009-04-28 03:00 EDT by Peng Huang
Modified: 2014-06-18 05:11 EDT (History)
9 users (show)

See Also:
Fixed In Version: 1.2.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:39:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test code for this problem. (152 bytes, text/plain)
2009-04-28 03:00 EDT, Peng Huang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 21560 None None None Never

  None (edit)
Description Peng Huang 2009-04-28 03:00:37 EDT
Created attachment 341528 [details]
Test code for this problem.

Description of problem:
libX11 does not support locale ne_NP.UTF-8

Version-Release number of selected component (if applicable):


How reproducible:
XSupportsLocale does not return the true if $LANG  is ne_NP.UTF-8

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 A S Alam 2009-04-28 03:41:16 EDT
Is version of libX11 is
libX11-1.2-3.fc11
Comment 2 Peng Huang 2009-05-05 01:26:57 EDT
Yeah.
libX11-1.2-3.fc11.i586
Comment 3 Jens Petersen 2009-05-05 01:31:09 EDT
Could you attach a patch and also check/file this issue upstream please at
freedesktop?
Comment 4 Peng Huang 2009-05-05 23:29:44 EDT
The upstream bug is http://bugs.freedesktop.org/show_bug.cgi?id=21560
Comment 5 Parag Nemade 2009-05-07 02:07:29 EDT
Here is test scratch build to check if one can input in ne_NP
http://koji.fedoraproject.org/koji/taskinfo?taskID=1340100
Comment 6 Parag Nemade 2009-05-25 04:32:13 EDT
To libX11 maintainers,
Can it be possible to build new libX11 with patch accepted upstream?
Thanks.
Comment 7 Fedora Update System 2009-05-26 03:09:45 EDT
libX11-1.2.1-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libX11-1.2.1-2.fc11
Comment 8 Fedora Update System 2009-05-27 15:08:03 EDT
libX11-1.2.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libX11'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5523
Comment 9 Bug Zapper 2009-06-09 10:41:40 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Ilpo Nyyssonen 2009-06-15 12:18:31 EDT
Is it intentional that several files under /usr/share/X11/locale are empty?

# rpm -qf locale.dir 
libX11-1.2.1-2.fc11.i586
# find -size 0
./C/Compose
./el_GR.UTF-8/XI18N_OBJS
./el_GR.UTF-8/XLC_LOCALE
./iscii-dev/Compose
./isiri-3342/Compose
./iso8859-11/Compose
./ja.S90/Compose
./ja.U90/Compose
./ja_JP.UTF-8/Compose
./ko_KR.UTF-8/Compose
./microsoft-cp1251/Compose
./microsoft-cp1255/Compose
./microsoft-cp1256/Compose
./nokhchi-1/Compose
./tatar-cyr/Compose
./th_TH/Compose
./th_TH.UTF-8/Compose
./tscii-0/Compose
./zh_CN.UTF-8/Compose
./zh_HK.UTF-8/Compose
./zh_TW.UTF-8/Compose
./am_ET.UTF-8/XI18N_OBJS
./am_ET.UTF-8/XLC_LOCALE
./fi_FI.UTF-8/XI18N_OBJS
./fi_FI.UTF-8/XLC_LOCALE

And why fi_FI.UTF-8 is not supported?

$ LC_ALL=fi_FI.UTF-8 xterm
Warning: locale not supported by Xlib, locale set to C
Comment 11 Fedora Update System 2009-06-15 21:38:52 EDT
libX11-1.2.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Parag Nemade 2009-06-16 00:30:04 EDT
(In reply to comment #10)
> Is it intentional that several files under /usr/share/X11/locale are empty?

> # rpm -qf locale.dir 
> libX11-1.2.1-2.fc11.i586
> # find -size 0
> ./C/Compose
> ./el_GR.UTF-8/XI18N_OBJS
> ./el_GR.UTF-8/XLC_LOCALE
> ./iscii-dev/Compose
> ./isiri-3342/Compose
> ./iso8859-11/Compose
> ./ja.S90/Compose
> ./ja.U90/Compose
> ./ja_JP.UTF-8/Compose
> ./ko_KR.UTF-8/Compose
> ./microsoft-cp1251/Compose
> ./microsoft-cp1255/Compose
> ./microsoft-cp1256/Compose
> ./nokhchi-1/Compose
> ./tatar-cyr/Compose
> ./th_TH/Compose
> ./th_TH.UTF-8/Compose
> ./tscii-0/Compose
> ./zh_CN.UTF-8/Compose
> ./zh_HK.UTF-8/Compose
> ./zh_TW.UTF-8/Compose
> ./am_ET.UTF-8/XI18N_OBJS
> ./am_ET.UTF-8/XLC_LOCALE
> ./fi_FI.UTF-8/XI18N_OBJS
> ./fi_FI.UTF-8/XLC_LOCALE

On my rawhide (F12) I got output as
./ja.S90/Compose
./microsoft-cp1251/Compose
./isiri-3342/Compose
./tatar-cyr/Compose
./ja.U90/Compose
./iso8859-11/Compose
./tscii-0/Compose
./microsoft-cp1255/Compose
./iscii-dev/Compose
./C/Compose
./am_ET.UTF-8/XI18N_OBJS
./am_ET.UTF-8/XLC_LOCALE
./th_TH.UTF-8/Compose
./zh_CN.UTF-8/Compose
./el_GR.UTF-8/XI18N_OBJS
./el_GR.UTF-8/XLC_LOCALE
./ja_JP.UTF-8/Compose
./nokhchi-1/Compose
./zh_HK.UTF-8/Compose
./zh_TW.UTF-8/Compose
./ko_KR.UTF-8/Compose
./th_TH/Compose
./microsoft-cp1256/Compose

My guess is that those encodings have no characters to represent them. like See zh_HK is using Big5 so you will find information in zh_HK.big5/Compose
Same for ko_KR.UTF-8. Look into ko/Compose. And for zh_CN.UTF-8 look for actual encoding zh_CN.gb18030



> 
> And why fi_FI.UTF-8 is not supported?
it is supported on F-11 also.

> 
> $ LC_ALL=fi_FI.UTF-8 xterm
> Warning: locale not supported by Xlib, locale set to C  

Yes. I got same output. I quickly tested fi_FI locale on my English F-12 desktop as
LANG=fi_FI.UTF-8 gedit
it worked.

I also see no xterm.mo is present for any locale. So looks like we have no translations for xterm. But I see many applications translations for fi_FI.

Note You need to log in before you can comment on or make changes to this bug.