Bug 497978 - Volume control / mixer issues with Fedora 11 [HDA Intel 8086:3001]
Volume control / mixer issues with Fedora 11 [HDA Intel 8086:3001]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-04-28 04:41 EDT by Ville-Pekka Vainio
Modified: 2009-05-21 11:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 05:10:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
alsa-info.txt of this computer (24.29 KB, text/plain)
2009-04-28 04:41 EDT, Ville-Pekka Vainio
no flags Details
The diff between original and fixed amixer -c0 output (865 bytes, text/plain)
2009-04-28 04:48 EDT, Ville-Pekka Vainio
no flags Details
The amixer output with default settings (3.90 KB, text/plain)
2009-04-29 04:35 EDT, Ville-Pekka Vainio
no flags Details
The amixer output with fixed volume settings (3.90 KB, text/plain)
2009-04-29 04:37 EDT, Ville-Pekka Vainio
no flags Details

  None (edit)
Description Ville-Pekka Vainio 2009-04-28 04:41:26 EDT
Created attachment 341535 [details]
alsa-info.txt of this computer

I'm filing this bug as per Adam Williamson's request https://www.redhat.com/archives/fedora-devel-list/2009-April/msg02321.html

I can't get enough volume with the alsa default settings, not even if the Banshee volume slider and the gnome panel volume slider are both at 100%.

This is what alsactl init says:

# alsactl init
Unknown hardware: "HDA-Intel" "SigmaTel STAC9271D" "HDA:83847627,80863001,00100201" "" ""
Hardware is initialized using a guess method

The alsa-info.txt file should be attached. I'll attach the alsa settings diff file next.
Comment 1 Ville-Pekka Vainio 2009-04-28 04:48:05 EDT
Created attachment 341537 [details]
The diff between original and fixed amixer -c0 output

I can't say that I know much about alsa, but here's what I did to get enough volume: I ran alsamixer -c0 and set PCM to full volume (dB gain 0). As that still wasn't enough, I added some Front volume as well, to dB gain -13.50. Now it's as much as my ears can possibly take :) I'm using headphones and there seems to be a Headphones volume slider as well, but that doesn't affect the volume at all.
Comment 2 Adam Williamson 2009-04-28 19:51:28 EDT
There's one more thing we need (sorry, this is my fault, the instructions were bad) - please attach the original amixer_before.txt and amixer_after.txt files, not just the diff. Turns out the diff doesn't have enough context. sorry!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Ville-Pekka Vainio 2009-04-29 04:35:12 EDT
Created attachment 341718 [details]
The amixer output with default settings
Comment 4 Ville-Pekka Vainio 2009-04-29 04:37:52 EDT
Created attachment 341720 [details]
The amixer output with fixed volume settings

Ok, the files should be attached now.
Comment 5 Paul W. Frields 2009-04-30 08:52:28 EDT
I believe my Intel HDA [8086:284b] hardware suffers from the same problem -- is the difference in my PCI ID sufficient to file an additional bug in this case?  Happy to do so if needed.
Comment 6 Lennart Poettering 2009-04-30 16:14:50 EDT
Sounds like a good candidate for inclusion in the ALSA db. Reassigning.
Comment 7 Adam Williamson 2009-04-30 19:24:20 EDT
Paul: the main PCI ID is not sufficient to identify Intel HDA chips uniquely, they almost all show that PCI ID, they're better identified by the subsystem IDs.

Please file a new bug following the instructions in comment #1 of the tracker bug (https://bugzilla.redhat.com/show_bug.cgi?id=497966 ) and let me know the number. If your hardware turns out to be the same as one of the existing reports, I'll close it as a dupe. Thanks!
Comment 8 Paul W. Frields 2009-05-01 09:49:33 EDT
Done, as bug 498612 -- thanks Adam.
Comment 9 Adam Williamson 2009-05-15 11:53:30 EDT
Jaroslav, was this one done in 1.0.20?
Comment 10 Jaroslav Kysela 2009-05-21 05:10:44 EDT
The alsa-utils-1.0.20-3 package should fix this issue. Reopen this bug if the problem persist.

Note You need to log in before you can comment on or make changes to this bug.