Bug 497996 - fsck.ext4 is missing in "linux rescue" mode
fsck.ext4 is missing in "linux rescue" mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks: F11Blocker/F11FinalBlocker
  Show dependency treegraph
 
Reported: 2009-04-28 06:49 EDT by Jan ONDREJ
Modified: 2009-04-28 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 10:05:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2009-04-28 06:49:57 EDT
Description of problem:
My rawhide root partition is broken and I'm trying to fix it. Because I can't boot my system from wrong partition, trying to use rescue mode, but there is no fsck.ext4 in rescue mode.

Version-Release number of selected component (if applicable):
11-Preview or devel/rawhide

How reproducible:
always

Steps to Reproduce:
1. boot with "linux rescue"
2. try to run "fsck.ext4" or run fsck on an ext4 partition
  
Actual results:
sh-4.0# fsck LABEL=/
fsck 1.41.4 (27-Jan-2009)
WARNING: couldn't open /etc/fstab: No such file or directory
fsck: fsck.ext4: not found
fsck: Error 2 while executing fsck.ext4 for /dev/sda2

Expected results:
running fsck

Additional info:
Please, add fsck.ext4 to Fedora 11 boot cd/dvd, because user was unable to fix their broken partitions.
I think this problem is critical for many of users.
Comment 1 Chris Lumens 2009-04-28 10:05:54 EDT
This will be fixed in the next build of anaconda.

Note You need to log in before you can comment on or make changes to this bug.