Bug 49800 - glibc-common won't install on clean system
glibc-common won't install on clean system
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-23 21:45 EDT by Robert van den Aker
Modified: 2016-11-24 10:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-23 21:45:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert van den Aker 2001-07-23 21:45:48 EDT
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Mac_PowerPC)



Description of problem:

I updated my mirror of RH 7.0 for alpha with glibc-common-2.2-12 
and glibc-2.2-12. Tried to install from that updated mirror onto clean 
system. Error message in /tmp/install.log:

Installing glibc-common.

unpacking of archive failed: cpio: Missing hard link

Running rpm -i glibc-common will install the package after the install, 
but then I have to remove and reinstall all packages that couldn't 
install properly because they needed glibc-common. This includes 
all packages that are configured by a perl script, because perl can't 
set the locale. Very annoying. Could glibc-common be rebuilt so that 
it will install on a clean system?



How reproducible:

Always



Steps to Reproduce:

1. Mirror RH 7.0 for alpha

2. Incorporate updates from 'updates' tree into 'Redhat/RPMS' tree, 
including update to glibc-2.2-12 and glibc-common-2.2-12.

3. Try installation off the updated 'RedHat/RPMS' tree.

	



Actual Results:  glibc-common didn't install. Subsequent packages 
didn't install properly.



Expected Results:  glibc-common should install on clean system.



Additional info:
Comment 1 Jakub Jelinek 2001-07-25 06:56:58 EDT
It is a rpm issue when there are hardlinks where some of the links are
present in one %lang(), others in other %lang() and one of those languages
is not selected for install.
You can get around this by forcing %_install_langs all, or by using some
more recent glibc (such as the one from 7.1 distribution - highly recommended).

Note You need to log in before you can comment on or make changes to this bug.