Bug 498019 - gallery2 is missing Smarty.class.php
gallery2 is missing Smarty.class.php
Status: CLOSED DUPLICATE of bug 497098
Product: Fedora
Classification: Fedora
Component: gallery2 (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 10:17 EDT by Vadym Chepkov
Modified: 2009-04-28 12:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 12:16:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2009-04-28 10:17:59 EDT
After upgrade to gallery2-2.3-7.fc10.noarch gallery became nonoperational:

PHP Fatal error:  GalleryCoreApi::require_once() [<a href='function.require'>function.require</a>]: Failed opening required '/usr/share/gallery2/modules/core/classes/../../../lib/smarty/Smarty.class.php' (include_path='.:/usr/share/pear:/usr/share/php') in /usr/share/gallery2/modules/core/classes/GalleryCoreApi.class on line 2827

$ ls /usr/share/gallery2/lib/smarty/Smarty.class.php
ls: cannot access /usr/share/gallery2/lib/smarty/Smarty.class.php: No such file or directory
Comment 1 Gwyn Ciesla 2009-04-28 10:54:56 EDT
Workaround:

ln -s ../../php/Smarty /usr/share/gallery2/lib/smarty

This is supposed to have been done in pretrans, investigating.
Comment 2 Vadym Chepkov 2009-04-28 12:09:33 EDT
This link is only created if the directory existed

if [ -d /usr/share/gallery2/lib/smarty ]; then
  rm -rf /usr/share/gallery2/lib/smarty
  ln -s ../../php/Smarty /usr/share/gallery2/lib/smarty
fi

And by the way, what is the current directory during rpm installation? I don't see any change directory command in the pre section to make relative link to work.
Comment 3 Gwyn Ciesla 2009-04-28 12:16:26 EDT

*** This bug has been marked as a duplicate of bug 497098 ***

Note You need to log in before you can comment on or make changes to this bug.