Bug 498036 - Elang JAM file definition breaks detection of postscript-files
Elang JAM file definition breaks detection of postscript-files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Novotny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 11:40 EDT by Sven
Modified: 2009-05-02 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.26-5.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-29 08:09:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven 2009-04-28 11:40:40 EDT
Description of problem:

missing quotes in /usr/share/magic for Erlang JAM file definition 

Version-Release number of selected component (if applicable):

$ file --version
file-4.26


How reproducible:

$ echo '1234Tue Mar 3 19:47:42 2009' |file -
  
Actual results:
/dev/stdin: Jan 22 14:32:44 MET 1991\011Erlang JAM file - version 4.2


Expected results:
/dev/stdin: ASCII text


Additional info:

this bug is mentioned in
https://bugs.launchpad.net/ubuntu/+source/file/+bug/248619
where it prevents printing of openoffice documents, that were
created on tuesdays.

please just add the missing quotes.

--- magic	2009-04-28 17:18:25.000000000 +0200
+++ magic.erlangfix	2009-04-28 17:19:15.000000000 +0200
@@ -4855,10 +4855,10 @@
 >8	string	BEAM		Erlang BEAM file
 
 # 4.2 version may have a copyright notice!
-4	string	Tue Jan 22 14:32:44 MET 1991	Erlang JAM file - version 4.2
-79	string	Tue Jan 22 14:32:44 MET 1991	Erlang JAM file - version 4.2
+4	string	Tue\ Jan\ 22\ 14:32:44\ MET\ 1991	Erlang JAM file - version 4.2
+79	string	Tue\ Jan\ 22\ 14:32:44\ MET\ 1991	Erlang JAM file - version 4.2
 
-4	string	1.0 Fri Feb 3 09:55:56 MET 1995	Erlang JAM file - version 4.3
+4	string	1.0\ Fri\ Feb\ 3\ 09:55:56\ MET\ 1995	Erlang JAM file - version 4.3
 
 #------------------------------------------------------------------------------
 # ESRI Shapefile format (.shp .shx .dbf=DBaseIII)
Comment 1 Fedora Update System 2009-04-29 06:28:12 EDT
file-4.26-5.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/file-4.26-5.fc10
Comment 2 Daniel Novotny 2009-04-29 06:29:57 EDT
hello Sven,
Thanks for your bug report and patch.
I fixed this in rawhide and F10; due to F11 development
freeze, I'm unable to fix this in F11 now, will do
it as soon as possible.
Comment 3 Sven 2009-04-29 08:09:28 EDT
Hello Daniel,

$ rpm -q file
file-4.26-5.fc10.i386
$ echo '1234Tue Mar 3 19:47:42 2009' |file -
/dev/stdin: ASCII text
$ file WillNotPrintOnTuesday.ps 
WillNotPrintOnTuesday.ps: PostScript document text conforming DSC level 3.0, Level 3

Thank you very much. Good luck for F11.
Comment 4 Fedora Update System 2009-05-02 12:41:16 EDT
file-4.26-5.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.