Bug 498043 - ibus Alt-grave trigger conflicts with openoffice.org
ibus Alt-grave trigger conflicts with openoffice.org
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 481098
  Show dependency treegraph
 
Reported: 2009-04-28 11:54 EDT by Warren Togami
Modified: 2009-06-15 21:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.1.0.20090609-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-15 21:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2009-04-28 11:54:56 EDT
ibus-1.1.0.20090423-1.fc11.x86_64
openoffice.org-writer-3.1.0-10.2.fc11.x86_64

Alt-grave trigger works without any issues in applications like firefox or gedit.

In openoffice.org-writer, Alt-grave to disable IM also causes the File menu to open.  This is very annoying.
Comment 1 Jens Petersen 2009-04-30 01:21:31 EDT
I couldn't reproduce in a Japanese desktop session with a fresh rawhide install.

Could you briefly describe the steps?
Comment 2 Warren Togami 2009-04-30 12:27:43 EDT
I just tested it, logging in to both en_US.UTF-8 and ja_JP.UTF-8.  Openoffice.org writer is affected in both LANG's.

It turns out the File menu is being activated both on Alt-grave trigger activation or deactivation depending on the state of the File menu before you press Alt-grave.
Comment 3 Peng Huang 2009-05-08 02:39:47 EDT
Alt + grave works fine on my box. I can not reproduce it too.
Comment 4 Jens Petersen 2009-06-04 00:27:20 EDT
Warren could you describe the steps more carefully?
Comment 5 Warren Togami 2009-06-05 11:47:47 EDT
1) Run openoffice writer.
2) Put cursor into document.
3) Alt-grave

Language bar appears.
File menu also appears.

4) Alt-grave
Language bar disappears.
File menu disappears.
Comment 6 Peng Huang 2009-06-07 22:47:12 EDT
I can not reproduce this problem fellow your steps. Are you using gtk immodule or XIM for openoffice?
Comment 7 Peng Huang 2009-06-08 07:14:11 EDT
Can you always reproduce this bug? Or it just happens sometime? I reproduced this problem. But it happens rarely.
Comment 8 Warren Togami 2009-06-08 14:33:43 EDT
Always
Comment 9 Bug Zapper 2009-06-09 10:43:03 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Fedora Update System 2009-06-09 19:47:44 EDT
ibus-1.1.0.20090609-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ibus-1.1.0.20090609-1.fc11
Comment 11 Peng Huang 2009-06-10 01:21:45 EDT
It has been fixed in ibus-1.1.0.20090609-1.fc11. Please test it.
Comment 12 Fedora Update System 2009-06-15 21:22:53 EDT
ibus-1.1.0.20090609-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.