Bug 498050 - delta download fails with "Package does not match intended download"
delta download fails with "Package does not match intended download"
Status: CLOSED DUPLICATE of bug 497459
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 12:21 EDT by Andreas Thienemann
Modified: 2009-04-28 12:34 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-28 12:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Thienemann 2009-04-28 12:21:00 EDT
Description of problem:
Updating a rawhide install fails with yum-presto enabled when updating from pulseaudio 0:0.9.15-10.fc11 to 0:0.9.15-11.fc11

Disabling yum-presto makes the update succeed

Version-Release number of selected component (if applicable):
yum-presto-0.4.5-4.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. Get the older pulseaudio rpms: wget http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-libs-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-module-bluetooth-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-libs-glib2-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-utils-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-module-x11-0.9.15-10.fc11.i586.rpm http://kojipkgs.fedoraproject.org/mash/rawhide-20090420/development/i386/os/Packages/pulseaudio-module-gconf-0.9.15-10.fc11.i586.rpm
2. Install them on the system: rpm -Uvh pulseaudio-0.9.15-10.fc11.i586.rpm pulseaudio-libs-0.9.15-10.fc11.i586.rpm pulseaudio-libs-glib2-0.9.15-10.fc11.i586.rpm pulseaudio-module-bluetooth-0.9.15-10.fc11.i586.rpm pulseaudio-module-gconf-0.9.15-10.fc11.i586.rpm pulseaudio-module-x11-0.9.15-10.fc11.i586.rpm pulseaudio-utils-0.9.15-10.fc11.i586.rpm --force
3. yum clean all
4. yum update
  
Actual results:
[root@workstation ~]# yum clean all
Loaded plugins: changelog, fastestmirror, presto, refresh-packagekit
Cleaning up Everything
Cleaning up list of fastest mirrors
[root@workstation ~]# yum update
Loaded plugins: changelog, fastestmirror, presto, refresh-packagekit
Determining fastest mirrors
 * livna: ftp-stud.fht-esslingen.de
 * rpmfusion-free-rawhide: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree-rawhide: ftp-stud.hs-esslingen.de
livna                                                                                                 | 2.4 kB     00:00     
livna/primary_db                                                                                      | 2.7 kB     00:00     
rawhide                                                                                               | 3.8 kB     00:00     
rawhide/primary_db                                                                                    | 8.4 MB     00:31     
rpmfusion-free-rawhide                                                                                | 3.3 kB     00:00     
rpmfusion-free-rawhide/primary_db                                                                     | 281 kB     00:00     
rpmfusion-nonfree-rawhide                                                                             | 3.3 kB     00:00     
rpmfusion-nonfree-rawhide/primary_db                                                                  |  92 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package pulseaudio.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-libs.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-libs-glib2.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-bluetooth.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-gconf.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-x11.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-utils.i586 0:0.9.15-11.fc11 set to be updated
--> Finished Dependency Resolution

Changes in packages about to be updated:

rawhide/other_db                                                                                      | 4.5 MB     00:16     
ChangeLog for: pulseaudio-0.9.15-11.fc11.i586, pulseaudio-libs-0.9.15-11.fc11.i586,
             : pulseaudio-libs-glib2-0.9.15-11.fc11.i586, pulseaudio-module-bluetooth-0.9.15-11.fc11.i586,
             : pulseaudio-module-gconf-0.9.15-11.fc11.i586, pulseaudio-module-x11-0.9.15-11.fc11.i586,
             : pulseaudio-utils-0.9.15-11.fc11.i586
* Wed Apr 22 14:00:00 2009 Warren Togami <wtogami@redhat.com> 0.9.15-11
- Bug #497214
  Do not start pulseaudio daemon if PULSE_SERVER directs pulse elsewhere.


Dependencies Resolved

=============================================================================================================================
 Package                                    Arch                Version                         Repository              Size
=============================================================================================================================
Updating:
 pulseaudio                                 i586                0.9.15-11.fc11                  rawhide                573 k
 pulseaudio-libs                            i586                0.9.15-11.fc11                  rawhide                517 k
 pulseaudio-libs-glib2                      i586                0.9.15-11.fc11                  rawhide                 20 k
 pulseaudio-module-bluetooth                i586                0.9.15-11.fc11                  rawhide                 76 k
 pulseaudio-module-gconf                    i586                0.9.15-11.fc11                  rawhide                 21 k
 pulseaudio-module-x11                      i586                0.9.15-11.fc11                  rawhide                 27 k
 pulseaudio-utils                           i586                0.9.15-11.fc11                  rawhide                 72 k

Transaction Summary
=============================================================================================================================
Install      0 Package(s)         
Update       7 Package(s)         
Remove       0 Package(s)         

Total download size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
rawhide/prestodelta                                                                                   |  57 kB     00:00     
Downloading DeltaRPMs:
(1/7): pulseaudio-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                             |  65 kB     00:00     
(2/7): pulseaudio-libs-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                        |  20 kB     00:00     
(3/7): pulseaudio-libs-glib2-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                  |  13 kB     00:00     
(4/7): pulseaudio-module-bluetooth-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                            |  19 kB     00:00     
(5/7): pulseaudio-module-gconf-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                |  16 kB     00:00     
(6/7): pulseaudio-module-x11-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                  |  15 kB     00:00     
(7/7): pulseaudio-utils-0.9.15-10.fc11_0.9.15-11.fc11.i586.drpm                                       |  48 kB     00:00     
Rebuilding rpms from deltarpms
(1/7): pulseaudio-0.9.15-11.fc11.i586.rpm                                                             | 573 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(2/7): pulseaudio-libs-0.9.15-11.fc11.i586.rpm                                                        | 517 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-libs-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(3/7): pulseaudio-libs-glib2-0.9.15-11.fc11.i586.rpm                                                  |  20 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-libs-glib2-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(4/7): pulseaudio-module-bluetooth-0.9.15-11.fc11.i586.rpm                                            |  76 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-module-bluetooth-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(5/7): pulseaudio-module-gconf-0.9.15-11.fc11.i586.rpm                                                |  21 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-module-gconf-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(6/7): pulseaudio-module-x11-0.9.15-11.fc11.i586.rpm                                                  |  27 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-module-x11-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.
(7/7): pulseaudio-utils-0.9.15-11.fc11.i586.rpm                                                       |  72 kB     00:00     
http://download.fedoraproject.org/pub/fedora/linux/development/i386/os/Packages/pulseaudio-utils-0.9.15-11.fc11.i586.rpm: (-1, u'Package does not match intended download')
Trying other mirror.


Error Downloading Packages:
  pulseaudio-libs-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-libs-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-module-gconf-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-module-gconf-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-libs-glib2-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-libs-glib2-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-module-bluetooth-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-module-bluetooth-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-utils-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-utils-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-module-x11-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-module-x11-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')
  pulseaudio-0.9.15-11.fc11.i586: failure: Packages/pulseaudio-0.9.15-11.fc11.i586.rpm from rawhide: (256, 'No more mirrors to try.')

[root@workstation ~]# 

Disabling yum-presto makes the transaction succeed:

[root@workstation ~]# yum update --disableplugin=presto
Loaded plugins: changelog, fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * rpmfusion-free-rawhide: ftp-stud.hs-esslingen.de
 * rpmfusion-nonfree-rawhide: ftp-stud.hs-esslingen.de
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package pulseaudio.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-libs.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-libs-glib2.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-bluetooth.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-gconf.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-module-x11.i586 0:0.9.15-11.fc11 set to be updated
---> Package pulseaudio-utils.i586 0:0.9.15-11.fc11 set to be updated
--> Finished Dependency Resolution

Changes in packages about to be updated:

ChangeLog for: pulseaudio-0.9.15-11.fc11.i586, pulseaudio-libs-0.9.15-11.fc11.i586,
             : pulseaudio-libs-glib2-0.9.15-11.fc11.i586, pulseaudio-module-bluetooth-0.9.15-11.fc11.i586,
             : pulseaudio-module-gconf-0.9.15-11.fc11.i586, pulseaudio-module-x11-0.9.15-11.fc11.i586,
             : pulseaudio-utils-0.9.15-11.fc11.i586
* Wed Apr 22 14:00:00 2009 Warren Togami <wtogami@redhat.com> 0.9.15-11
- Bug #497214
  Do not start pulseaudio daemon if PULSE_SERVER directs pulse elsewhere.


Dependencies Resolved

=============================================================================================================================
 Package                                    Arch                Version                         Repository              Size
=============================================================================================================================
Updating:
 pulseaudio                                 i586                0.9.15-11.fc11                  rawhide                573 k
 pulseaudio-libs                            i586                0.9.15-11.fc11                  rawhide                517 k
 pulseaudio-libs-glib2                      i586                0.9.15-11.fc11                  rawhide                 20 k
 pulseaudio-module-bluetooth                i586                0.9.15-11.fc11                  rawhide                 76 k
 pulseaudio-module-gconf                    i586                0.9.15-11.fc11                  rawhide                 21 k
 pulseaudio-module-x11                      i586                0.9.15-11.fc11                  rawhide                 27 k
 pulseaudio-utils                           i586                0.9.15-11.fc11                  rawhide                 72 k

Transaction Summary
=============================================================================================================================
Install      0 Package(s)         
Update       7 Package(s)         
Remove       0 Package(s)         

Total download size: 1.3 M
Is this ok [y/N]: y
Downloading Packages:
(1/7): pulseaudio-0.9.15-11.fc11.i586.rpm                                                             | 573 kB     00:01     
(2/7): pulseaudio-libs-0.9.15-11.fc11.i586.rpm                                                        | 517 kB     00:01     
(3/7): pulseaudio-libs-glib2-0.9.15-11.fc11.i586.rpm                                                  |  20 kB     00:00     
(4/7): pulseaudio-module-bluetooth-0.9.15-11.fc11.i586.rpm                                            |  76 kB     00:00     
(5/7): pulseaudio-module-gconf-0.9.15-11.fc11.i586.rpm                                                |  21 kB     00:00     
(6/7): pulseaudio-module-x11-0.9.15-11.fc11.i586.rpm                                                  |  27 kB     00:00     
(7/7): pulseaudio-utils-0.9.15-11.fc11.i586.rpm                                                       |  72 kB     00:00     
-----------------------------------------------------------------------------------------------------------------------------
Total                                                                                        145 kB/s | 1.3 MB     00:09     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : pulseaudio-libs                                                                                      1/14 
  Updating       : pulseaudio                                                                                           2/14 
  Updating       : pulseaudio-module-bluetooth                                                                          3/14 
  Updating       : pulseaudio-libs-glib2                                                                                4/14 
  Updating       : pulseaudio-utils                                                                                     5/14 
  Updating       : pulseaudio-module-x11                                                                                6/14 
  Updating       : pulseaudio-module-gconf                                                                              7/14 
  Cleanup        : pulseaudio-module-x11                                                                                8/14 
  Cleanup        : pulseaudio-libs-glib2                                                                                9/14 
  Cleanup        : pulseaudio                                                                                          10/14 
  Cleanup        : pulseaudio-utils                                                                                    11/14 
  Cleanup        : pulseaudio-module-gconf                                                                             12/14 
  Cleanup        : pulseaudio-libs                                                                                     13/14 
  Cleanup        : pulseaudio-module-bluetooth                                                                         14/14 

Updated:
  pulseaudio.i586 0:0.9.15-11.fc11                            pulseaudio-libs.i586 0:0.9.15-11.fc11                          
  pulseaudio-libs-glib2.i586 0:0.9.15-11.fc11                 pulseaudio-module-bluetooth.i586 0:0.9.15-11.fc11              
  pulseaudio-module-gconf.i586 0:0.9.15-11.fc11               pulseaudio-module-x11.i586 0:0.9.15-11.fc11                    
  pulseaudio-utils.i586 0:0.9.15-11.fc11                     

Complete!


Expected results:
Either Delta correctly used or a working fallback to download only.
Comment 1 Jonathan Dieter 2009-04-28 12:34:36 EDT

*** This bug has been marked as a duplicate of bug 497459 ***

Note You need to log in before you can comment on or make changes to this bug.