Bug 498090 - Add to documentation on cluster setup
Add to documentation on cluster setup
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
1.1
All All
high Severity medium
: 1.3
: ---
Assigned To: Alison Young
MRG Quality Engineering
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 16:14 EDT by Mike Cressman
Modified: 2012-09-21 08:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-17 01:03:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cressman 2009-04-28 16:14:35 EDT
Description of problem:

A couple clarifications on the documentation in section 7.1 (Messaging Clusters), "Starting the AIS service":

* at the end of number 3., the line reads "The subnet is the bitwise AND of the mask and the local address, 192.168.1.255".  The mask is 255.255.255.0 and the local address is 192.168.1.103, so the bitwise AND should be 192.168.1.0, not 192.168.1.255.

* from the example in number 2., the mcastport setting (in this case 5405) requires that your firewall is set up to allow port 5405/udp.  Otherwise the ais service won't start correctly.


Version-Release number of selected component (if applicable):
1.1 Messaging User Guide
Comment 1 Jonathan Robie 2009-09-09 11:07:16 EDT
This now says the following:

The bindnetaddr entry should be set to the subnet you will use for cluster multicast. Use the same subnet for for all hosts in the cluster. You can find the subnet with /sbin/ifconfig. For example:

# /sbin/ifconfig eth0
  eth0      Link encap:Ethernet  HWaddr 00:1E:37:88:72:8A  
            inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0

In this case the local address is 192.168.1.103 and the subnet mask is 255.255.255.0. The bindnetaddr should be set to the bitwise AND of the mask and the local address. For this example, it is 192.168.1.0.
Comment 4 Alison Young 2011-03-17 01:03:53 EDT
Closed as fix already implemented

Also closed due to bug being against unsupported book version and to clear off docs bug radar. If still applicable against current version (2.0), feel free reopen bug.

Note You need to log in before you can comment on or make changes to this bug.