Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 49810 - wrong exit code
wrong exit code
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 04:40 EDT by Gerald Teschl
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-24 04:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-07-24 04:40:12 EDT
Description of Problem:
rpm -qp gives exit code 0 even if the package is broken. Please fix.

How Reproducible:


Steps to Reproduce:
$  rpm -qp ttfonts-ja-1.0-3.noarch.rpm ; echo $?
warning: Expected size:      8763422 =
lead(96)+sigs(160)+pad(0)+data(8763166)
warning:   Actual size:       153600
ttfonts-ja-1.0-3
0

Actual Results:
exit code 0

Expected Results:
exit code != 0

Additional Information:
Comment 1 Jeff Johnson 2001-07-24 09:40:28 EDT
This is now a warning, not an error. Since it's now possible to put installed
bits back into a package using --repackage, and the version of zlib used
causes the package to have a different size, there's no way to differntiate
that case from the more typical case (at the moment) of a damaged package.

Use rpm -K to verify package integrity.

Note You need to log in before you can comment on or make changes to this bug.