Bug 498117 - F11 Preview x86-64 Live Xorg hangs after login on Opteron/ATI chipset and video.
F11 Preview x86-64 Live Xorg hangs after login on Opteron/ATI chipset and video.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 18:35 EDT by ed leaver
Modified: 2010-06-28 08:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ed leaver 2009-04-28 18:35:07 EDT
Description of problem:


Version-Release number of selected component (if applicable):
F-11 Preview X86_64 Live (28 April 2009)

How reproducible:
Always: just boot from live CD

Steps to Reproduce:
1. Boot after media test from x86-64 Live CD
2. Wait for login prompt, leave language, keyboard at default English-US 
   (mouse works at this point)
3. Click on "login" button.
  
Actual results:
Get Fedora background, "busy swirl" behind frozen cursor, disk activity light.

Expected results:
Get Fedora background, "busy swirl" behind frozen cursor, then eventually gdm/gnome and whatever desktop widgets the Live CD is supposed to bring up. Active mouse, inactive disk light.


Additional info:
1. MB: Abit AT8 s939 ATI RD480 with ULI 1575 SB, Opteron 170, 4GB ECC DDR2
2. Video: PowerColor  ATI Technologies Inc RV410 [Radeon X700 (PCIE) driving two similar CRT displays.
3. Boot flags: I try eliminating "quiet" and "rhgb" and adding "noacpi" and "apic=yes" to make no difference. Adding "nomodeset" to the previous results in the boot process hanging right after "setting domain localhost.localdomain", so boot never completes to the login prompt. With modeset left to default X hangs right after clicking "login" button as described above. Is this when X starts? Does a modeset take place at this point? Inquiring minds want to know...
Comment 1 Bug Zapper 2009-06-09 10:44:19 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 ed leaver 2009-09-05 16:05:21 EDT
This bug seems to get around, most recently masquerading as a SATA driver problem in #514124 against F11 release, and as boot hangs during udev in #521004 against F12 rawhide. Both of these are worked around by blacklisting snd_hda_intel, which suggests kernel memory corruption by that driver or one of its co-requisites.
Comment 3 ed leaver 2009-09-05 19:41:15 EDT
I've essentially replicated this bug with the Fedora 11 x96_64 LIVE release CD.
The problems go away when sound is disabled in BIOS. But before then: 

A. After removing rhgb and queit, and either adding nomodeset or not, the boot proceeds to 
Starting udev...
/bin/mknod '/dev/loop0' : File exists
...
/bin/mknod '/dev/loop7' : File exists [OK]
Setting hostname localhost.localdomain
(Hangs with hdd activity light lit.
hardware reset


B. Adding modprobedebug to boot flags shows
1. all acpi drivers load
2. all sound drivers load, last being snd_hda_intel
3. udev_event[*] exec failed of program /sbin/alsactl
4. Checking filesystems:
   /etc/rc.d/rc.sysinit: line 568 /sbin/fsck Input Output error
   /etc/rc.d/rc.sysinit: line 587 /bin/plymouth Input Output error
   /etc/init.d/functions: line 494 /usr/bin/plymout Input Output error
   *** An error occurred during filesystem checks
   *** Dropping yuou to a shell
   sulogin: error while reading shared libraries: /lib64/libfreebl3.so: cannot read file data: Input Output error
   Unmounting filesytems
   Automiatic reboot in progress
   (hangs, hdd light NOT lit)
hardware reset

C. Disable sound in BIOS and reboot. Fedora 11 x86_64 LIVE CD appears to boot and run fine with NO changes to boot flags, i.e leaving KMS enabled.
   "Computer" widget shows all SATA and IDE filesystems, but not md raids.
   Firefox comes up, network auto initialized without prompting.
   gnome-display-properties does not configure spanning displays on my dual CRT system, but that's an entirely separate issue.

D. Conclusion: The F11/F12 snd_hda_intel driver and/or requisites are sick.

Thanks!
Ed Leaver
Comment 4 Jérôme Glisse 2009-10-14 07:34:35 EDT
Can you test with fedora 12 livecd and report if it works with it.
Comment 5 ed leaver 2009-10-17 12:56:48 EDT
Yes, the problem persists with F12-Snap3-x86_64-Live. But testing the live CD is too painful even to be fun. This problem appears to be identical with Bug 521004 where I have a F12 hard disk install, working network, yum, gcc, gdb, kmemtrace, a reliable boot when snd-hda-intel is blacklisted, easy bug reproduction by un-blacklisting followed by modprobe snd-hda-intel, and relatively fast recovery via booting in CentOS and re-blacklisting the /F12/etc/modeprobe.d/blacklist.conf. Unless someone else has a compelling reason, I really don't see the point in further LiveCD testing until after the problem is resolved in the hard disk install, against le kernel-du-jour. Are there any kernel driver-level memory sniffers in addition to kmemtrace? I haven't tried kmemtrace yet, and don't wish to if there is something more appropriate for this particular task. Any buggestions? Should we move this discussion to Bug 521004? Thanks!
Ed Leaver
Comment 6 Matěj Cepl 2009-11-05 13:27:43 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 7 ed leaver 2009-11-06 00:17:32 EST
Yes, the problem still exists with the 2.6.31.5-96.fc12.x86_64 kernel. But it doesn't seem to be in Xorg as initially reported, but rather in the snd_hda_intel driver stack. (See my previous two posts.) When snd_hda_intel is blacklisted F12 seems to work fine. Awfully quiet, though...
Comment 8 Bug Zapper 2010-04-27 09:59:20 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2010-06-28 08:15:12 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.