This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 498128 - can no longer build PDFs as of the morning of 29th April
can no longer build PDFs as of the morning of 29th April
Status: CLOSED NOTABUG
Product: Publican
Classification: Community
Component: publican (Show other bugs)
2.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Michael Hideo
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 21:15 EDT by Darrin Mison
Modified: 2010-11-23 22:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 22:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
packages installed on Wed 29 Apr 2009 (19.06 KB, text/plain)
2009-04-28 21:15 EDT, Darrin Mison
no flags Details

  None (edit)
Description Darrin Mison 2009-04-28 21:15:05 EDT
Created attachment 341682 [details]
packages installed on Wed 29 Apr 2009

Description of problem:
trying to build a pdf results in a java.lang.ClassNotFoundException exception

Version-Release number of selected component (if applicable):
publican-doc-0.45-0.el5
publican-redhat-0.19-0.el5
publican-WebSite-obsoletes-1.0-0.el5
publican-gimp-0.5-2.el5
publican-jboss-0.18-0.el5
publican-0.45-0.el5
publican-ovirt-0.7-0.el5
publican-fedora-0.18-0.el5

How reproducible:
everytime

Steps to Reproduce:
1. make clean pdf-en-US
  
Actual results:
...
Making portrait pages on A4 paper (210mmx297mm)
Loading Xslthl configuration from file:///usr/share/xslthl/xslthl-config.xml...
Running FOP:
Exception in thread "main" java.lang.NoClassDefFoundError: error:
Caused by: java.lang.ClassNotFoundException: error:
	at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
	at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
Could not find the main class: error:.  Program will exit.
make: *** [pdf-en-US] Error 1

Expected results:
a pdf

Additional info:
version of publican hasn't changed so I suspect an update in dependancies has broken it

Output of rpm -qa --queryformat '%{installtime} (%{installtime:date}) %{name}\n' | sort -n attached.  Only included items since it last worked.
Comment 1 Darrin Mison 2009-04-28 22:25:18 EDT
Resolved.  

I'd set $JAVA_HOME previously in .bashrc and pointed it to a directory that longer existed after the update.  

Now pointing at the symlink /usr/lib/jvm/java-1.5.0-sun instead of the versioned directory

Note You need to log in before you can comment on or make changes to this bug.