Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 49813 - rpm perl version incompatibility
rpm perl version incompatibility
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-07-24 06:36 EDT by Dave J
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-07-24 09:51:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave J 2001-07-24 06:36:39 EDT
Description of Problem:
( Surprised this hasn't already been found, reported, and fixed, but I've 
searched a number of places and can't find any reference to it !!! )

Redhat v7.1 installs perl version 5.006 ( reported as 5.6.0 from rpm )
A number of RPM's require perl >= 5.00503

Attempts to install RPM stop with message
error: failed build dependencies:
        perl >= 5.00503 is needed by (eg)perl-Authen-PAM-0.08-6

How Reproducible:
Every time.

Steps to Reproduce:
1. Use RH v 7.1 out of the box
2. Attempt to build or install an RPM that has BuildRequires: or Requires: 
perl >= 5.00503

Actual Results:

error: failed build dependencies:
        perl >= 5.00503 is needed by (for example )perl-Authen-PAM-0.08-6

Expected Results:
Builds / Installs correctly

Additional Information:

Think this relates to the changes in way version numbers are handled ??
For RH7.1
rpm -qa reports


perl itself reports version number is 5.006 ( print "$]" )

Have tried this with a number of RPM's requiring perl >= 5.00503. All 
result in the same message.
Comment 1 Jeff Johnson 2001-07-24 09:19:30 EDT
This is a package problem, not an rpm problem. perl-5.6.0 has an ep[och, so
the dependency on perl in each package needs an explicit epoch, as in
	Requires: perl >= 0:5.00503
Note the explicit "0:" epoch
Comment 2 Dave J 2001-07-24 09:51:44 EDT
So this means that now many RPMS are broken and need to be changed !? ie no 
backward compatibility ( including probably many perl related RPMS's provided 
with RH7.1 ) ???

Comment 3 Jeff Johnson 2001-07-24 10:11:32 EDT
It means anything you want it to mean. Meanwhile, I've described the fix
and don't wish to argue further.
Comment 4 Dave J 2001-07-24 12:07:41 EDT
Sorry - didn't mean to come across as argumentative. I just want to confirm 
what you are saying, because I am quite new to RPM's and linux and the 
implications seem significant.

If I am understanding what you are saying, I need either:
1. contact the producers of the RPMS that have this, and ask them to upgrade 
their packages, or 
2. if they are available on the net, update the relevant source RPMS, or
3. Fix them for my application, but then things get out of sync with what is 
publicly available.

Comment 5 Jeff Johnson 2001-07-24 12:38:40 EDT
Apologies, I didn't mean to appear gruff either.

Yes, there's a lot of CPAN packaging breakage because of the need
(i.e. so that perl-5.6.0 is "newer" than perl-6.00503, it's not "newer"
because 6 < 503) for an epoch in the perl package.

That means that an epoch must be explicitly included in all packages
that depend on perl forever more:
	Requires: perl >= 0:5.00503
Can't be helped ...

Note You need to log in before you can comment on or make changes to this bug.