Bug 498134 - rpc.gssd ccachedir option not working
rpc.gssd ccachedir option not working
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nfs-utils (Show other bugs)
5.3
i386 Linux
low Severity medium
: rc
: ---
Assigned To: Steve Dickson
yanfu,wang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-28 22:13 EDT by Tim Czerwonka
Modified: 2011-07-21 07:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: nfs-utils-1.0.9-52.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-21 07:34:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch fixes the problem, same as above URL (450 bytes, patch)
2009-04-28 22:13 EDT, Tim Czerwonka
no flags Details | Diff

  None (edit)
Description Tim Czerwonka 2009-04-28 22:13:43 EDT
Created attachment 341687 [details]
this patch fixes the problem, same as above URL

Description of problem:

The option to rpc.gssd for specifying a krb5 credential cache other than /tmp (-d) doesn't work as specified in the current RHEL5.3 rpm: nfs-utils-1.0.9-40.el5.i386.rpm

[root@tornado ~]# /usr/sbin/rpc.gssd -d /tmp
[root@tornado ~]# /usr/sbin/rpc.gssd -d /var/tmp
rpc.gssd: ccachedir path name too long



Version-Release number of selected component (if applicable):
nfs-utils-1.0.9-40.el5.i386.rpm

How reproducible:

Execute the command, specify an option to -d that's something other than /tmp.

Steps to Reproduce:
/usr/sbin/rpc.gssd -d /var/tmp
 
Actual results:
"rpc.gssd: ccachedir path name too long"


Expected results:
non-error, credential cache dir is set as directed


Additional info:
This is fixed in nfs-utils-1.1.2

Problem summarized also at this URL:
http://www.opensubscriber.com/message/nfs@lists.sourceforge.net/5730327.html
Comment 1 Tim Czerwonka 2011-01-10 13:16:05 EST
Still a problem in nfs-utils-1.0.9-47.el5_5.2.x86_64.rpm
Comment 2 RHEL Product and Program Management 2011-01-11 15:06:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 18:10:55 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 5 yanfu,wang 2011-05-16 01:59:01 EDT
reproduced on nfs-utils-1.0.9-51.el5:
      Beaker Test information:
                         HOSTNAME=nec-em24-1.rhts.eng.bos.redhat.com
                            JOBID=85206
                         RECIPEID=175166
                    RESULT_SERVER=127.0.0.1:7095
                           DISTRO=RHEL5.7-Server-20110413.1
                     ARCHITECTURE=i386
**  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **  **
[root@nec-em24-1 ~]# vim /etc/sysconfig/nfs 
[root@nec-em24-1 ~]# /home/wangyf/.ssh/known_hosts:146
[root@nec-em24-1 ~]# rpc.gssd -d /var/tmp
rpc.gssd: ccachedir path name too long
[root@nec-em24-1 ~]# rpm -qa|grep nfs-utils
nfs-utils-1.0.9-51.el5
nfs-utils-lib-1.0.8-7.6.el5

verified against nfs-utils-1.0.9-52.el5 on i386 and x86_64:
# cat /etc/sysconfig/nfs|grep -w SECURE_NFS
SECURE_NFS="yes"
# rpc.gssd -d /var/tmp
# rpc.gssd -d /tmp
[root@hp-xw6400-02 ~]# echo $?
0
Comment 6 errata-xmlrpc 2011-07-21 07:34:27 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-1048.html

Note You need to log in before you can comment on or make changes to this bug.