Bug 498145 - The sound level is very low [HDA Intel 1458:a002]
The sound level is very low [HDA Intel 1458:a002]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-04-29 00:45 EDT by Alexander Dyadyun
Modified: 2009-05-21 11:53 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-21 05:11:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info, amixer_before, amixer_after (6.29 KB, application/zip)
2009-04-29 00:45 EDT, Alexander Dyadyun
no flags Details
unpacked files (32.75 KB, text/plain)
2009-05-02 10:08 EDT, Alexander Dyadyun
no flags Details
unpacked files (amixer_after) (4.27 KB, text/plain)
2009-05-02 10:09 EDT, Alexander Dyadyun
no flags Details
unpacked files (amixer_before) (4.27 KB, text/plain)
2009-05-02 10:11 EDT, Alexander Dyadyun
no flags Details

  None (edit)
Description Alexander Dyadyun 2009-04-29 00:45:40 EDT
Created attachment 341703 [details]
alsa-info, amixer_before, amixer_after

Description of problem:
The sound level is very low.

Version-Release number of selected component (if applicable):


How reproducible:
100% on my system (Gigabyte GA-Q35M-S2/ICH9DO/ALC888)

Steps to Reproduce:
1. Set all output sound volume regulators in gnome volume control & PulseAudio Volume Control to maximum.
2. Load any audio/video file in kplayer/amarok/Rhytmbox music player
3. Set sound volume of kplayer/amarok/Rhytmbox music player to maximum level and try to hear anything.
  
Actual results:
Output sound level is 10-15% from sound level under win2003 on the same output.

Expected results:
Output sound level is 100% from sound level under win2003 on the same output.

Additional info: Headphones in green jack on rear panel. After adjusting sound level in "alsamixer -c0" problem is gone.
Comment 1 Lennart Poettering 2009-04-30 15:59:12 EDT
Please do not attach zip files. That makes it very difficult to have a look into them.

Could you please reattach those files seperately?
Comment 2 Alexander Dyadyun 2009-05-02 10:08:31 EDT
Created attachment 342175 [details]
unpacked files
Comment 3 Alexander Dyadyun 2009-05-02 10:09:13 EDT
Created attachment 342176 [details]
unpacked files (amixer_after)
Comment 4 Alexander Dyadyun 2009-05-02 10:11:19 EDT
Created attachment 342177 [details]
unpacked files (amixer_before)

Sorry for late answer.
Comment 5 Lennart Poettering 2009-05-02 11:01:39 EDT
diff looks like this:

--- b	2009-05-02 16:59:56.000000000 +0200
+++ a	2009-05-02 16:59:49.000000000 +0200
@@ -2,7 +2,7 @@
   Capabilities: pvolume pvolume-joined pswitch pswitch-joined
   Playback channels: Mono
   Limits: Playback 0 - 31
-  Mono: Playback 17 [55%] [-21.00dB] [on]
+  Mono: Playback 31 [100%] [0.00dB] [on]
 Simple mixer control 'Headphone',0
   Capabilities: pswitch
   Playback channels: Front Left - Front Right
@@ -14,15 +14,15 @@
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 255
   Mono:
-  Front Left: Playback 155 [61%] [-20.00dB]
-  Front Right: Playback 155 [61%] [-20.00dB]
+  Front Left: Playback 255 [100%] [0.00dB]
+  Front Right: Playback 255 [100%] [0.00dB]
 Simple mixer control 'Front',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
-  Front Left: Playback 17 [55%] [-21.00dB] [on]
-  Front Right: Playback 17 [55%] [-21.00dB] [on]
+  Front Left: Playback 31 [100%] [0.00dB] [on]
+  Front Right: Playback 31 [100%] [0.00dB] [on]
 Simple mixer control 'Front Mic',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
@@ -73,8 +73,8 @@
   Playback channels: Front Left - Front Right
   Limits: Playback 0 - 31
   Mono:
-  Front Left: Playback 23 [74%] [0.00dB] [on]
-  Front Right: Playback 23 [74%] [0.00dB] [on]
+  Front Left: Playback 31 [100%] [12.00dB] [on]
+  Front Right: Playback 31 [100%] [12.00dB] [on]
 Simple mixer control 'Mic',0
   Capabilities: pvolume pswitch
   Playback channels: Front Left - Front Right
@@ -109,8 +109,8 @@
   Capabilities: cvolume cswitch
   Capture channels: Front Left - Front Right
   Limits: Capture 0 - 31
-  Front Left: Capture 19 [61%] [12.00dB] [on]
-  Front Right: Capture 19 [61%] [12.00dB] [on]
+  Front Left: Capture 31 [100%] [30.00dB] [on]
+  Front Right: Capture 31 [100%] [30.00dB] [on]
 Simple mixer control 'Capture',1
   Capabilities: cvolume cswitch
   Capture channels: Front Left - Front Right

Looks like a candidate for ALSA db inclusion.
Comment 6 Adam Williamson 2009-05-15 11:53:47 EDT
Jaroslav, was this one done in 1.0.20?
Comment 7 Jaroslav Kysela 2009-05-21 05:11:38 EDT
The alsa-utils-1.0.20-3 package should fix this issue. Reopen this bug if the problem persist.

Note You need to log in before you can comment on or make changes to this bug.