Bug 498153 - Thunderbird does not display messages according to their Content-type character set
Thunderbird does not display messages according to their Content-type charact...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 02:11 EDT by Basil Mohamed Gohar
Modified: 2018-04-11 10:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-15 11:01:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of non-reproduction (248.51 KB, image/png)
2009-05-15 10:44 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Basil Mohamed Gohar 2009-04-29 02:11:46 EDT
Description of problem:
Thunderbird does not display a message with a non-default character set according to the content-type as specified in the header.

Version-Release number of selected component (if applicable):
thunderbird-3.0-2.1.beta2.fc11.i586
Comment 1 Matěj Cepl 2009-05-15 10:44:23 EDT
Created attachment 344166 [details]
screenshot of non-reproduction

Sorry, as you can see on this Russian spam (sorry, for using spam, but that's the best collection of weird-languages emails I have ;-)).

It has

Content-Type: text/plain; charset=windows-1251
Content-Transfer-Encoding: 8bit

and it is displayed correctly (yes, this is correct Russian, I can read it).

I would suspect some of your Thunderbird plugins making havoc. Are you able to reproduce the problem even when starting TB in the safe mode (start it in the terminal with -safe-mode as a parameter on the command line)? If yes, could you please attach some example of the message (hopefully not private) which shows the described issue (and a screenshot how it looks like on your computer), please?

Thank you very much
Comment 2 Basil Mohamed Gohar 2009-05-15 11:01:35 EDT
Thank you for helping me.  I found out I had checked the "Apply default to all messages" option in the Inbox folder properties.  I had misread the checkbox and thought it would apply a default, but NOT override messages' own charset setting, but apparently it does the opposite (upon more careful reading).

Sorry for that.  This bug can be closed!  Thanks again!

Note You need to log in before you can comment on or make changes to this bug.