This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 498158 - Pulseaudio volume drops by ~30% every time track changes
Pulseaudio volume drops by ~30% every time track changes
Status: CLOSED DUPLICATE of bug 488532
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On: 488532
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 03:43 EDT by Basil Mohamed Gohar
Modified: 2009-07-29 22:04 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-29 22:04:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vvvv log when audacious is played, stopped. (60.45 KB, text/plain)
2009-05-25 11:39 EDT, David Timms
no flags Details

  None (edit)
Description Basil Mohamed Gohar 2009-04-29 03:43:35 EDT
Description of problem:
When playing multiple audio files in audacious, each subsequent track or file is played at 30% lower volume than the one before.  Sound disappears when pulseaudio volume is below 50% (maybe another issue).

Version-Release number of selected component (if applicable):
audacious-1.5.1-7.fc11.i586
pulseaudio-0.9.15-11.fc11.i586

How reproducible:
Every time

Steps to Reproduce:
1. Load multiple files in audacious
2. Play them one after another, or change tracks
  
Actual results:
Sound volume drops by ~30% after each track change.

Expected results:
Playback volume should not change between tracks
Comment 1 Rand All 2009-05-07 18:48:22 EDT
I just noticed the exact same thing with XMMS using the Pulseaudio output plugin.  So the problem is probably in Pulse, not Audacious.

All my packages are up-to-date as of this posting.
Comment 2 David Timms 2009-05-25 11:39:50 EDT
Created attachment 345334 [details]
pulseaudio -vvvv log when audacious is played, stopped.

(In reply to comment #0)
> Description of problem:
> When playing multiple audio files in audacious, each subsequent track or file
> is played at 30% lower volume than the one before.  Sound disappears when
> pulseaudio volume is below 50% (maybe another issue).
I might be just misinterpreting this description, but I find that the audio level drops to about 30% at the start and stop, or new track.

While audacious shows it's volume knob at say 70%, it seems this value has not taken effect in the gnome-volume-control-applet mixer/pulseaudio mixer. Clicking the volume slider knob, without moving it sideways sets the correct mixer value, and the audio becomes ... audible. Can you confirm this behaviour on your hardware ?

maybe interesting part (not restoring volume) is:
I: module-stream-restore.c: Restoring device for stream sink-input-by-application-name:Audacious.

D: module-stream-restore.c: Not restoring volume for sink input sink-input-by-application-name:Audacious, because already set.

I: module-stream-restore.c: Restoring mute state for sink input sink-input-by-application-name:Audacious.

D: reserve-wrap.c: Successfully acquired reservation lock on device 'Audio1'
I: alsa-sink.c: Trying resume...
Comment 3 David Timms 2009-05-25 12:03:22 EDT
(In reply to comment #2)
> I might be just misinterpreting this description, but I find that the audio
> level drops to about 30% at the start and stop, or new track.
The g-v-c-applet shows the application level disappear when stop is pressed.
audacious continues to show level as 80% (or whatever you left it on).

> While audacious shows it's volume knob at say 68%, it seems this value has not
> taken effect in the gnome-volume-control-applet mixer/pulseaudio mixer.
At play, the g-v-c-a application level stream is added to the application tab, and the value show is around 80%. Output volume~=80% as well.
In pavucontrol playback:audacious level=81%, output device=81%, but audio is not heard.

> Clicking the volume slider knob, without moving it sideways sets the correct
> mixer value, and the audio becomes ... audible.
g-v-c-a app:audacious level jumps down a 10%
pavucontrol: level jumps down from 80 to 68%
====
actually with further testing I was able to see Basil's issue: 
level started at 68%. 
stop, play, lev=30%. 
stop, play, lev=0%.
stop, play, lev=68%
stop, play, lev=68%
stop, play, lev=68%
while typing this in, get a "no title" dialog:
"Connection failed: Connection terminated, Close" box. (i think it came from g-v-c-a preferenced dialog). And it can't control, nor see the streams anymore.
When it occurred, pavucontrol disappear of the screen as well.

Any logs etc needed to track this down.
Note: is there a possibility that running both pavucontrol and g-v-c-a | preferences at the same time will lead to pulseaudio death ?
Comment 4 Bug Zapper 2009-06-09 10:45:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Nicola Soranzo 2009-07-27 13:49:44 EDT
Triaged:

Reproducible also with latest updates:

audacious-1.5.1-9.fc11.i586
audacious-plugins-1.5.1-6.fc11.i586
pulseaudio-0.9.15-14.fc11.i586

Using PulseAudio Output Plugin, the volume is decreased when starting Audacious or when changing track (i.e. double clicking on it), not during normal playlist listening.
Comment 6 Michael Schwendt 2009-07-27 17:41:09 EDT
The decreasing volume levels in Audacious are passed in via a PulseAudio pa_context_get_sink_input_info() callback. If volume is set to 100% in either gst-mixer or Audacious, the volume level stays at 65536. If lowered, every callback supplies smaller values. [Strangely, 50% is not 32768.]

I think this is another dupe of bug 488532.
Comment 7 Lennart Poettering 2009-07-29 22:04:44 EDT

*** This bug has been marked as a duplicate of bug 488532 ***

Note You need to log in before you can comment on or make changes to this bug.