Bug 498185 - user switching: "initial" screan not completely redrawn (sometimes)
user switching: "initial" screan not completely redrawn (sometimes)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 07:21 EDT by Michal Hlavinka
Modified: 2009-05-04 00:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-04 00:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (860.46 KB, image/jpeg)
2009-04-29 07:23 EDT, Michal Hlavinka
no flags Details

  None (edit)
Description Michal Hlavinka 2009-04-29 07:21:42 EDT
Description of problem:
When repeatedly switching from one user to another one, sometimes background is not redrawn completely in screen lock (it should be black with password dialog), but about one third of the screen is filled with grey and white chessboard. But I  don't know if it's nouveau related or KDE4 related. See attached screenshot.

tested on Fedora 11 Snap1 x86_64 Live KDE

How reproducible:
10 %

Steps to Reproduce:
1. start another session and log in
2. switch from first to second and back (no need unlock screensaver)
3. repeat step 2 several times
  
Actual results:
about one third of the screen is filled with grey and white chessboard

Expected results:
black screen with password dialog

Additional info:
Comment 1 Michal Hlavinka 2009-04-29 07:23:52 EDT
Created attachment 341737 [details]
screenshot
Comment 2 Ben Skeggs 2009-04-29 07:39:33 EDT
Can you test with the "nv" and/or "vesa" drivers and see if the problem is reproducible there?  Also, your Xorg.0.log and the output of the dmesg command after the issue has occurred would be useful.

Thanks!
Comment 3 Michal Hlavinka 2009-04-29 16:23:07 EDT
I've tested it with nv (rpm -e xorg-x11-drv-nouveau and reboot), but wasn't able to reproduce it. Then I've tested it with nouveau in Fedora 11 Prev1 x86_64 Live KDE, but I wasn't able to reproduce it with this newer version.
Comment 4 Ben Skeggs 2009-05-04 00:59:22 EDT
Ok, thank you.  I'll close this a fixed then!

Note You need to log in before you can comment on or make changes to this bug.