Bug 498238 - cobbler check still requests cman to be installed, even though it already is
cobbler check still requests cman to be installed, even though it already is
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cobbler (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Michael DeHaan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 10:56 EDT by Jacob Hunt
Modified: 2009-05-06 17:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 17:39:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jacob Hunt 2009-04-29 10:56:48 EDT
Description of problem:

cobbler check wants cman installed to use the power management modules, even though it already is installed.


Version-Release number of selected component (if applicable):

cobbler-1.6.2-1.fc11.noarch
cman-3.0.0-15.rc1.fc11.i586

How reproducible:

every time

Steps to Reproduce:
1. install cobbler
2. install cman
3. cobbler check
  
Actual results:

[jhunt@jhunt ~]
-> sudo cobbler check
/usr/lib/python2.6/site-packages/Cheetah/CacheRegion.py:30: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
The following potential problems were detected:
#0: change 'disable' to 'no' in /etc/xinetd.d/tftp
#1: since iptables may be running, ensure 69, 80, and 25151 are unblocked
#2: fencing tools were not found, and are required to use the (optional) power management features. install cman to use them

Expected results:

no information about sman not being installed.

Additional info:
Comment 1 Michael DeHaan 2009-04-29 11:07:11 EDT
Thanks for the heads up, I've copied this over to Trac here so we don't lose it. 

https://fedorahosted.org/cobbler/ticket/444
Comment 2 Michael DeHaan 2009-05-06 17:39:21 EDT
F11 has a package called 'fence-agents' rather than cman, which is why the check message is wrong.  We have this fixed for 1.8, cobbler will require this package on that OS.

Note You need to log in before you can comment on or make changes to this bug.