Bug 498249 - Can't switch mapping for physical buttons, but not tap
Can't switch mapping for physical buttons, but not tap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-x-target
  Show dependency treegraph
 
Reported: 2009-04-29 11:39 EDT by Bastien Nocera
Modified: 2009-10-26 21:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 21:25:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 599623 None None None Never

  None (edit)
Description Bastien Nocera 2009-04-29 11:39:49 EDT
Either through lack of documentation, or because it's really not supported, there's no way to switch button mapping without reassigning the tap behaviour as well.

It should be possible to swap the left/right physical buttons on the touchpad, but let the "tap" be button 1.

Currently, gnome-settings-daemon will ignore all the touchpads. Once it's possible to swap only the physical buttons, we can remove that behaviour in gnome-settings-daemon.
Comment 1 Peter Hutterer 2009-04-29 18:07:13 EDT
This is awkward but: the button mapping is handled in the server, tapping in the driver.

So if you switch tapping to 3-2-1 and the device button mapping to 3-2-1, tap 1 comes through as button 1 while phys. button 1 comes through as button 3.

I'll add this to the man page.
Comment 2 Bastien Nocera 2009-04-29 18:54:47 EDT
How would we do this programmatically?
Comment 3 Peter Hutterer 2009-04-29 20:28:24 EDT
The button mapping through XSetDeviceButtonMapping as usual, the TapButton by changing the property on the synaptics driver. 

http://cvs.fedoraproject.org/viewvc/rpms/gnome-settings-daemon/F-11/gnome-settings-daemon-2.26.0-support-touchpads.patch?revision=1.1&view=markup

set_tap_to_click (gboolean state) does it for the normal 1/3/2 mapping, you'd just need to set it to 3/1/2.
Comment 4 Adam Williamson 2009-07-17 14:10:06 EDT
Discussed at today's critical bug review meeting. Jesse opined that it's an annoyance, not truly an issue that should block release. I didn't have a strong opinion. So we're dropping it to F12Target on that basis.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Peter Hutterer 2009-10-26 02:30:14 EDT
Filed as GNOME bug 599623 (https://bugzilla.gnome.org/show_bug.cgi?id=599623)

Fixed in build: http://koji.fedoraproject.org/koji/taskinfo?taskID=1768089
Requested for F12 final.
Comment 6 Adam Williamson 2009-10-26 21:25:07 EDT
tag request was accepted, closing.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.