Bug 498252 - RHN Tools Packages Not Installable After Sync
RHN Tools Packages Not Installable After Sync
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
Depends On:
  Show dependency treegraph
Reported: 2009-04-29 11:41 EDT by Devan Goodwin
Modified: 2009-04-30 00:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-29 13:46:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Devan Goodwin 2009-04-29 11:41:19 EDT
Description of problem:

After satellite-sync'ing RHEL 5 + Tools + VT, rhnmd package is visible in the web UI but not when doing yum search on a system that has the Tools channel assigned to it. yum search rhnmd on the client shows no results. Scheduling from the web UI and running rhn_check results in: 

D: Sending back response (32, 'Failed: Packages failed to install properly: No package(s) available to install', {'version': '1', 'name': 'package_install_failure'})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. satellite-sync -crhel-i386-server-5 -crhel-i386-server-vt-5 -crhn-tools-rhel-i386-server-5
2. assign client these channels
3. yum search rhnmd on client (no results)
4. schedule rhnmd install from web UI and rhn)check on client.
Actual results:

Package install fails.

Additional info:

Re-tried satellite-sync but this did not correct the problem.

[root@satellite ~]# cd /var/satellite/
[root@satellite satellite]# ls
redhat  rhn
[root@satellite satellite]# find . -name "*rhnmd*"
[root@satellite satellite]# 

No errors visible in xmlrpc log or httpd error_log.

Will keep this sat/client intact for further debugging.

Problem appears for other packages in tools like rhncfg. Download link in the web UI works.
Comment 1 Devan Goodwin 2009-04-29 12:56:06 EDT
Wow, few hours later I re-ran the commands to search for the packages on the client, and they just appeared. :O I don't think I did *anything* to the Satellite during this time.

Lost my reproducer, was this a delayed task of some kind? I didn't notice any unusual load on the box.
Comment 2 Pradeep Kilambi 2009-04-29 13:25:50 EDT
Yea its odd. I saw the same on jsherill's sat. I just cleared the cache and it fixed the issue. I guess in your first attempt there is some cache mismatch and generation was in progress and it fixed it once that was complete. I'm not able to reproduce again either. I'll keep a watch and see why this is could be happening.

Note You need to log in before you can comment on or make changes to this bug.