Bug 498265 - EFI boot missing from DVD
EFI boot missing from DVD
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
15
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 12:50 EDT by John Reiser
Modified: 2013-01-10 00:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-17 15:14:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2009-04-29 12:50:25 EDT
Description of problem: Fedora-11-Preview-i386-DVD.iso does not have EFI boot, yet Fedora-11-Preview-i386-netinst.iso does.  When booted on Apple Macintosh mini i686 with Intel 945 graphics (hold down Option key during chime), then selecting EFI boot leads to GRUB with one choice, and eventually X11 fails to start but anaconda reverts to text mode.  The netinst.iso also offers "Windows" boot, but that leads to VGA text of:
-----
     1.

     2.
  Select type of CD-ROM:
-----
and no response to keyboard.

On the same Mac mini, the Preview DVD offers only "Windows" boot which leads to syslinux and all options crash immediately after "running /sbin/loader\n
waiting for hardware to initialize..."  Booting the DVD with " nomodeset" works (bug #494390).

Version-Release number of selected component (if applicable):
Fedora-11-Preview-i386-DVD.iso
Fedora-11-Preview-i386-netinst.iso

How reproducible: every time


Steps to Reproduce:
1. obtain from mirrors (download netinst, jigdo DVD) and burn to media
2. attempt to boot on Apple Macintosh mini i686 with Intel 945 graphics
3.
  
Actual results: EFI boot on netinst.iso, no EFI boot on DVD.


Expected results: EFI boot on all i686 and x86_64 media


Additional info:
Comment 1 Jeremy Katz 2009-04-29 16:07:40 EDT
I seem to remember Peter saying this was intentional because there are machines that don't work with the EFI-able boot image.
Comment 2 Bug Zapper 2009-06-09 10:48:11 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jesse Keating 2009-12-22 15:01:59 EST
Yep, confirmed.  Not expected to be on anything other than boot/netinst.iso
Comment 4 Eugene Kanter 2011-08-19 13:42:44 EDT
found it reported again here: http://urlgrey.net/?p=315
Comment 5 Dennis Gilmore 2012-04-17 15:14:19 EDT
Fedora 16 at the least supports EFI as does F17

Note You need to log in before you can comment on or make changes to this bug.