Bug 498286 - NSSRAWHASH missing
NSSRAWHASH missing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nspr (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kai Engert (:kaie)
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 14:03 EDT by jrspurrier
Modified: 2009-08-14 22:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-07 18:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jrspurrier 2009-04-29 14:03:58 EDT
Description of problem:
Attempting to run a program and it wont run and giving me a file or libary not found


Version-Release number of selected component (if applicable):


How reproducible:
Evertime

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
bin/app_settings/mozilla-runtime-linux-i686/libfreebl3.so: version `NSSRAWHASH_3.12.3' not found (required by /lib/libcrypt.so.1)
*** Unclean shutdown. ***


Expected results:
Program should load and run

Additional info: 

I checked and the file is installed
yum list installed nss-softokn-freebl
Loaded plugins: presto, refresh-packagekit
Installed Packages
nss-softokn-freebl.i586                 3.12.3-3.fc11                  installed
Comment 1 Jakub Jelinek 2009-04-30 05:26:06 EDT
That means you have too old version of libfreebl3.so in your LD_LIBRARY_PATH that overrides the system libfreebl3.so.

If it is from an rpm shipped with Fedora, this would be a big in whatever package that includes, otherwise it is a problem with wherever that mozilla-runtime-linux-i686/libfreebl3.so comes from.
Comment 2 jrspurrier 2009-04-30 22:41:37 EDT
The app you run from the directory. And i know it worked fine from Fedora 10 default install. Im guessing the libfree is too old in the application to mesh with Fedora
Comment 3 jrspurrier 2009-05-01 23:56:25 EDT
Somewhat solved... I know this isnt a good fix but by copying the libcrypt.so.1 from FC 10 to the FC11 /lib got the application to work properly... so i would assume it means the files in the application are too old
Comment 4 Kai Engert (:kaie) 2009-05-07 15:26:12 EDT
what application is it that you are trying to run?

how did you get the application? from fedora or elsewhere?

If (app is not from fedora) and (you decide the bug is no in fedora) 
then {please close this bug}

strings /path/to/your/application/libfreebl3.so |grep -i "NSS 3"
should tell you the version of the freebl that came with your app
Comment 5 Kai Engert (:kaie) 2009-05-07 15:27:18 EDT
cc'ing Bob and Elio FYI
Comment 6 jrspurrier 2009-05-07 18:54:59 EDT
Version of NSS
@(#)NSS 3.11.4 Basic ECC  Mar 17 2008 13:36:43
$Header: NSS 3.11.4 Basic ECC  Mar 17 2008 13:36:43 $

I will go ahead and close the bug as it seems its an issue with the libs in the application which is from elsewhere is too old seeing that copying the libcrypt files from Fedora 10 made the application work fine
Comment 7 Karl Tomlinson 2009-08-14 22:36:55 EDT
A newer libfreebl3 will not solve the problem unless that app chooses to build with FREEBL_NO_DEPEND set in the environment.
https://bugzilla.mozilla.org/show_bug.cgi?id=497251#c44

I guess the bug is in upstream NSS, but it looks like the problem was created by 
the patch by rrelyea@redhat.com at
https://bugzilla.mozilla.org/attachment.cgi?id=348594&action=diff
adding a NSSRAWHASH_3.12 node only when FREEBL_NO_DEPEND is set.

Note You need to log in before you can comment on or make changes to this bug.