Bug 498287 - No sound after resume with snd_cs46xx
No sound after resume with snd_cs46xx
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
: 160751 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 14:08 EDT by Chris Schumann
Modified: 2010-06-28 10:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:16:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
ALSA Project 305 None None None Never

  None (edit)
Description Chris Schumann 2009-04-29 14:08:13 EDT
Description of problem: Machine will not play any sound after suspend/resume cycle. Sound players will not advance time indicator.


Version-Release number of selected component (if applicable): Installed from F11 Preview, all updates installed.
[root@localhost ~]# modinfo snd_cs46xx
filename:       /lib/modules/2.6.29.1-111.fc11.i586/kernel/sound/pci/cs46xx/snd-cs46xx.ko
license:        GPL
description:    Cirrus Logic Sound Fusion CS46XX
author:         Jaroslav Kysela <perex@perex.cz>
srcversion:     A714ECC413813DC5929B3F0
alias:          pci:v00001013d00006004sv*sd*bc*sc*i*
alias:          pci:v00001013d00006003sv*sd*bc*sc*i*
alias:          pci:v00001013d00006001sv*sd*bc*sc*i*
depends:        snd-pcm,snd-ac97-codec,snd-page-alloc,snd,snd-rawmidi,gameport
vermagic:       2.6.29.1-111.fc11.i586 SMP mod_unload 586 
parm:           index:Index value for the CS46xx soundcard. (array of int)
parm:           id:ID string for the CS46xx soundcard. (array of charp)
parm:           enable:Enable CS46xx soundcard. (array of bool)
parm:           external_amp:Force to enable external amplifer. (array of bool)
parm:           thinkpad:Force to enable Thinkpad's CLKRUN control. (array of bool)
parm:           mmap_valid:Support OSS mmap. (array of bool)


How reproducible:
Every time.

Steps to Reproduce:
1. Play any sound file.
2. Suspend then resume machine.
3. Attempt to play sound again.
  
Actual results:
No sound.

Expected results:
Funky grooves.

Additional info:
Link to smolt profile:
http://www.smolts.org/client/show/pub_e7b7cb45-5407-4167-a282-206f50502896
Comment 1 Bug Zapper 2009-06-09 10:48:33 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Oliver Henshaw 2009-09-15 18:20:21 EDT
This is also reported in bug #160751 - which has been automatically closed by F9 EOL. There is a fix in an unstable branch of alsa (and has been for around a year, depending how you count) but it hasn't been pushed to the kernel.

I tried out the fix (with a modified fedora kernel) and it worked for me - but I've since updated to a new fedora kernel without the fix.
Comment 3 Oliver Henshaw 2009-09-17 05:20:37 EDT
A stable link for the branch with the fix is http://git.kernel.org/?p=linux/kernel/git/tiwai/sound-unstable-2.6.git;a=shortlog;h=topic/cs46xx-resume - again, it solves things for me.
Comment 4 Oliver Henshaw 2009-10-13 12:33:23 EDT
So the fix has been in sound-unstable git for exactly a year now. Could we have it in fedora please?
Comment 5 Oliver Henshaw 2009-12-03 11:41:06 EST
Ping?
Comment 6 Jaroslav Kysela 2009-12-07 03:20:46 EST
*** Bug 160751 has been marked as a duplicate of this bug. ***
Comment 7 Jaroslav Kysela 2009-12-07 03:39:34 EST
I asked to merge this code to the ALSA development tree on the alsa-devel maling list. It means that it will be (most probably) in next Linux kernels.
Comment 8 Jaroslav Kysela 2009-12-08 07:10:05 EST
After discussion with the patch author - we had some troubles with the machine freeze after second suspend/resume cycle. Could you confirm, that the mentioned patch does not cause any machine freeze?
Comment 9 Chris Schumann 2009-12-08 07:57:47 EST
I'd be happy to, but I need instructions on how to do that. I'm happy to install any version of any distro and build from source, but need info on how to get it done.
Comment 10 Chris Schumann 2009-12-08 08:03:52 EST
(In reply to comment #9)
The machine currently has Fedora 12 installed, if that matters.
Comment 11 Bug Zapper 2010-04-27 10:00:20 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 12 Oliver Henshaw 2010-04-27 11:08:26 EDT
The coming 2.6.34 looks like it has patches for this. But I haven't been able to test it, nor have I attempted to rebuild the fedora 12 kernel with these patches.
Comment 13 Bug Zapper 2010-06-28 08:16:01 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 14 Chris Schumann 2010-06-28 10:42:53 EDT
Issue still present in Fedora 13 using kernel 2.6.33.5-124 as of June 28.
Comment 15 Chris Schumann 2010-06-28 10:45:40 EDT
I'd be happy to contact the patch author and try out the patch. Sound is choppy on the machine now in the best case after the revamp of the sound system. I can build kernels, but need a bit more instruction. -- Chris

Note You need to log in before you can comment on or make changes to this bug.