Bug 498289 - [2.6.29] Sound issue with Intel HD Audio Controller
[2.6.29] Sound issue with Intel HD Audio Controller
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 14:14 EDT by Lukas Tvrdy
Modified: 2009-12-18 04:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 04:23:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages related to sound issues (24.39 KB, text/plain)
2009-04-29 14:14 EDT, Lukas Tvrdy
no flags Details
amixer -c0 output (14.25 KB, text/plain)
2009-04-29 14:16 EDT, Lukas Tvrdy
no flags Details
alsa mixer screen (52.38 KB, image/png)
2009-05-03 04:02 EDT, Lukas Tvrdy
no flags Details
alsa mixer screen [All] (55.89 KB, image/png)
2009-05-03 04:04 EDT, Lukas Tvrdy
no flags Details

  None (edit)
Description Lukas Tvrdy 2009-04-29 14:14:27 EDT
Created attachment 341812 [details]
/var/log/messages related to sound issues

Description of problem:
Sound is not working. I can't setup the volume, nor to check it.

Inspired by bug https://bugzilla.redhat.com/show_bug.cgi?id=485734
and http://forums.fedoraforum.org/showpost.php?p=1206905&postcount=14

Version-Release number of selected component (if applicable):
2.6.29.2-52.fc10.i686 from updates-testing

How reproducible:
often

Steps:
1. try to play YouTube video, amarok or anything else (mplayer, vlc)

HW Device:
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

# dmesg
ALSA sound/pci/hda/hda_intel.c:635: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x021f000a

# alsa-info
http://www.alsa-project.org/db/?f=2a66b31d6091234c507d31b72c299d8d80db0adc

# alsactl init
Unknown hardware: "HDA-Intel" "Nvidia ID 3" "HDA:111d76b2,103c3603,00100302 HDA:10de0003,10de0101,00100000" "" ""
Hardware is initialized using a guess method

#amixer
ALSA lib pulse.c:272:(pulse_connect) PulseAudio: Unable to connect: Connection refused
amixer: Mixer attach default error: Connection refused

Attachment about amixer_before will be added.
var/log/messages added so far

I run pulseaudio with -vvvv -D flags
Comment 1 Lukas Tvrdy 2009-04-29 14:16:56 EDT
Created attachment 341814 [details]
amixer -c0 output
Comment 2 Adam Williamson 2009-04-29 15:27:26 EDT
what happens if you try to play something with mplayer - can you please reboot to get a clean setup, run 'mplayer somefile', and paste all the console output you get?
Comment 3 Lukas Tvrdy 2009-04-29 17:19:19 EDT
Here is 
mplayer -msglevel all=6 file.wav
http://fpaste.org/paste/10555
Comment 4 Adam Williamson 2009-04-29 21:04:37 EDT
I see you have it configured to prefer the SDL audio output, can you try again with:

mplayer -ao pulse file.wav

and paste that? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Lukas Tvrdy 2009-05-01 04:58:26 EDT
I noticed that I tested alsamixer as root, so he could not connect.
When I try to run it as user, it works. But I see fewer options then on 2.6.27 kernels.

I made a screenshot of KMix, you can notice that PCM volume control is missing.
http://imagebin.ca/view/SkRHJAn.html

Here it is mplayer, with pulse:

MPlayer SVN-r28461-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU     P7350  @ 2.00GHz (Family: 6, Model: 23, Stepping: 6)
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /mnt/diskC/KDE4/share/apps/blinken/sounds/lose.wav.
Audio only file format detected.
==========================================================================
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 1 ch, s16le, 705.6 kbit/100.00% (ratio: 88200->88200)
Selected audio codec: [pcm] afm: pcm (Uncompressed PCM)
==========================================================================
AO: [pulse] 44100Hz 1ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A:   0.0 (00.0) of 0.2 (00.2) ??,?%

Exiting... (End of file)
Comment 6 Adam Williamson 2009-05-01 13:07:37 EDT
this is looking more like an actual ALSA bug than anything to do with Pulse and volume controls. but, can you post a screenshot of alsamixer instead? I can't read kmix.
Comment 7 Lukas Tvrdy 2009-05-02 18:13:17 EDT
Hi, 

I tested the alsamixer, but nothing special there.

Card: PulseAudio
Chip: PulseAudio
View:  Playback [Capture] 
All
Item: Capture     

And I setup sound to 80-100%.
Comment 8 Adam Williamson 2009-05-02 19:57:38 EDT
sorry, you need to do 'alsamixer -c0' to see the card's controls rather than the pulse 'card'.
Comment 9 Lukas Tvrdy 2009-05-03 04:02:49 EDT
Created attachment 342204 [details]
alsa mixer screen
Comment 10 Lukas Tvrdy 2009-05-03 04:04:10 EDT
Created attachment 342205 [details]
alsa mixer screen [All]

I tested also headphones and there is no sound from them too.
Comment 11 Adam Williamson 2009-05-04 15:50:45 EDT
OK, so PCM is there and set to a decent value. If you go over to the two elements just labelled "Digital" with "Digital" above them in yellow text, then press up and down to scroll through the choices (they look like list-style elements), what are the choices? What is the full name of those two elements (it'll be displayed in the Item: field at the top of alsamixer, when they're highlighted)?

sorry for this painful process, I'm just trying to identify the problem exactly...
Comment 12 Lukas Tvrdy 2009-05-05 14:43:04 EDT
Analog Inputs, Mixer, Digital Mic 1, Digital Mic 2

Anyway I resolved it half-way finally. In KMix [1] there is Analog Loopback and Analog Loopback 2. If I mute these two options, I have sound back! You can see on the picture just one Analog Loopback muted. So when I mute them both I have sound :) It is weird, but it somehow works now.

[1] http://imagebin.ca/view/SkRHJAn.html
Comment 13 Adam Williamson 2009-05-05 15:26:19 EDT
Looks like a bad ALSA default, then. Assigning. Thanks.
Comment 14 Bug Zapper 2009-11-18 06:52:54 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2009-12-18 04:23:03 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.