Bug 498292 - Clarify GFS2 documentation on adding journals
Clarify GFS2 documentation on adding journals
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Documentation-cluster (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Steven J. Levine
Content Services Development
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 14:38 EDT by Steven J. Levine
Modified: 2009-09-03 12:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 12:45:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven J. Levine 2009-04-29 14:38:20 EDT
Description of problem:

From Eduardo Damato:

Can we add some enhancements to the following page?

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Global_File_System_2/s1-manage-addjournalfs.html

Points I would recommend we cover:

1- gfs2_jadd only suceeds if there is free space 'on the FS', therefore gfs2_jadd will fail if the FS is full, even if the LV containing the FS has been extended and is larger than the FS size.

2- Following up from point (1), GFS2 is fundamentally different from GFS1. In GFS1 new journals are added 'outside' the FS, ie, one needs to extend the LV, gfs_jadd, in GFS1, if the FS has the same size of the LV it is not possible to add a journal, it's necessary to extend the LV and then add the journal.

3- My recommendation would be that we add 'red and green boxes' just as you've done on the link below, explaining points (1) and (2):

http://www.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/5/html/Global_File_System_2/s1-manage-repairfs.html


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Steven J. Levine 2009-06-19 16:38:15 EDT
I've been looking at how to add this information to the GFS2 manual. 

There's a section a the beginning of the document that lists the operational differences between GFS and GFS2, and that's where I think specific comparisons between the file systems belong (rather than in the general admin. documentation). There already exists a bullet point about how you can add journals dynamically in GFS2 because journals are files rather than "embedded metadata" (I must have gotten that phrase from an early spec), but I have rewritten this slightly to emphasize the difference in how you add journals in the two file systems and to note that there must be space on a file system to add a journal dynamically. The working draft now says this under the heading "Adding Journals Dynamically"

" In GFS file systems, journals are embedded metadata that exists outside of the file system, making it necessary to extend the size of the logical volume that contains the file system before adding journals. In GFS2 file systems, journals are plain (though hidden) files.  This means that for GFS2 file systems, journals can be dynamically added as additional servers mount a filesystem, as long as space remains on the file system for the additional journals. For information on adding journals to a GFS2 file system, see Adding Journals to a File System."

In the section on gfs2_jadd, I have added a note. This bug suggests that add two boxes -- a warning and a note -- but technically a warning contains information that will prevent you from damaging your file system or data. I don't think a failing gfs2_jadd command quite fits this, so I've put the new information into a note that says this (as a first draft):

"NOTE
If a GFS2 file system is full, the gfs2_jadd will fail, even if the logical volume containing the file system has been extended and is larger than the file system. This is because in a GFS2 file system, journals are plain files rather than embedded metadata, so simply extending the underlying logical volume will not provide space for the journals."

I will shortly be sending out the updated GFS2 manual for review (for RHEL 5.4) and I will be sure to include Eduardo on the review list.
Comment 2 Steven J. Levine 2009-09-03 12:45:39 EDT
With the release of RHEL 5.4, I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.