This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 4983 - under certain conditions tripwire produces a segmentation fault
under certain conditions tripwire produces a segmentation fault
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: tripwire (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-08 10:26 EDT by arto.selonen
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-12 19:40:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description arto.selonen 1999-09-08 10:26:21 EDT
With certain tw.config files tripwire produces a
segmentation fault message. This happens right after
phase 3 has started. It will produce the same result
with -initialize, -update, and without arguments.

I've briefly looked into the src.rpm code, but only to
realize that it is probably a leaky pointer *somewhere*.
This, unfortunately, means that tripwire is not working
correctly, and thus renders it unreliable.

(I can produce the fault at will with one system/config,
if anybody cares to look further into this).
Comment 1 Tim Powers 1999-09-24 22:25:59 EDT
Try using the tripwire located in
ftp://rawhide.redhat.com/rawhide/powertools

Please reopen this bug if you conltinue to have problems with
tripwire.

Tim

Note You need to log in before you can comment on or make changes to this bug.