Bug 498347 - KMS:RV410:Radeon X700 Pro dual-monitors display only as "mirror screens", 2nd video card will not register [NEEDINFO]
KMS:RV410:Radeon X700 Pro dual-monitors display only as "mirror screens", 2nd...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 20:46 EDT by eric magaoay
Modified: 2010-06-28 08:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-28 08:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcepl: needinfo? (ericm24x7)


Attachments (Terms of Use)
xorg.0.log output (195.42 KB, text/plain)
2009-04-29 20:46 EDT, eric magaoay
no flags Details
xrandr output (503 bytes, text/plain)
2009-04-29 20:47 EDT, eric magaoay
no flags Details
monitors.xml content (867 bytes, text/plain)
2009-04-29 20:47 EDT, eric magaoay
no flags Details
dmesg output (32.24 KB, text/plain)
2009-04-29 20:49 EDT, eric magaoay
no flags Details
jgbiii Xorg.0.log (424.72 KB, text/plain)
2009-05-17 18:59 EDT, James G. Brown III
no flags Details
jgbiii monitors.xml (869 bytes, text/xml)
2009-05-17 19:19 EDT, James G. Brown III
no flags Details
2 Linux bugs saved as pert of my current task list for 2 Fedora 12 installations. (18.93 KB, application/vnd.oasis.opendocument.text)
2010-01-31 02:24 EST, Bruce Martin
no flags Details

  None (edit)
Description eric magaoay 2009-04-29 20:46:23 EDT
Created attachment 341851 [details]
xorg.0.log output

Description of problem:
Running "gnome-display-properties" to unset "mirror screens" option does not work. The dual-monitors displays remain a mirror image of each other.  
Also the 2nd video card (3rd display) would not register on the configuration setup.

HARDWARE: 
   Nvidia GeForce4 MX 4000 (dual-head monitors)
   ATI Radeon X700 Pro

Version-Release number of selected component (if applicable):
xorg-x11-server 1.6.1-6.fc11

How reproducible:
persistent

Steps to Reproduce:
1.gnome-display-properties
2. uncheck "mirror screens"
3. 
  
Actual results:
each monitors remain a mirror image of the other. 3rd video (nv) not visible.
Comment 1 eric magaoay 2009-04-29 20:47:08 EDT
Created attachment 341852 [details]
xrandr output
Comment 2 eric magaoay 2009-04-29 20:47:56 EDT
Created attachment 341853 [details]
monitors.xml content
Comment 3 eric magaoay 2009-04-29 20:49:28 EDT
Created attachment 341854 [details]
dmesg output
Comment 4 eric magaoay 2009-05-04 13:27:57 EDT
CORRECTION: ATI Radeon X700 Pro is the dual-head and NOT Geforce4 MX400. Sorry.
Comment 5 James G. Brown III 2009-05-17 18:59:32 EDT
Created attachment 344359 [details]
jgbiii Xorg.0.log

Right, I have a problem with an ATI Radeon X600 in that the two outputs (VGA-0 and DVI-0) will do nothing other than clone.

2.6.29.3-140.fc11.i686.PAE
xorg-x11-drv-ati-6.12.2-14.fc11.i586

attaching Xorg.0.log, not using an xorg.conf.
Comment 6 James G. Brown III 2009-05-17 19:03:18 EDT
Additionally, In the upper left corner of the screen I see DELL 19" (both red). From the workspace icon (bottom right corner of the screen) it appears as if the resolution might be right, but both outputs VGA-0 and DVI-0 only show what seems to be VGA-0 (DELL 19" in red). If I change the green output (DVI-0) in gnome-display properties to the left of the red output (VGA-0) both screens then only show the green DELL 19" in the upper left hand corner... 

Please advise on what additional information you may need. 

- James
Comment 7 James G. Brown III 2009-05-17 19:19:24 EDT
Created attachment 344361 [details]
jgbiii monitors.xml

Right, I have a problem with an ATI Radeon X600 in that the two outputs (VGA-0 and DVI-0) will do nothing other than clone.

I have tried using Virtual in xorg.conf and manually changing with xrandr to no avail. 

And through dumb luck I managed to get this working... Lets see if it survives a reboot. AFAICT, this is what I did;

$ gnome-display-properties
    Move the green output square to the left of the red output square; apply
$ gnome-terminal (had to fire up a new terminal (praise be to nautilus-
                  open-terminal)
$ gnome-display-properties
    Move the red output square to the right of the green output square; apply
    Move the green output square to the right of the red output square; apply

Wonky I know, but it survived a reboot... not certain that I want to mess with it anymore, but will give it a shot if there is any useful information that we can get from reproduction. 

- James
Comment 8 James G. Brown III 2009-05-17 19:28:07 EDT
Alright, removing monitors.xml brought back the cloning issue. Doing the following seems to be consistently working;

$ gnome-display-properties
     Uncheck "Mirror screens"; apply
     Move the green square to the left of the red square; apply

Alt+F2 and fire up gnome-terminal

$ gnome-display-properties
     Move the red square to the right of the green square; apply

Voila! Spanning Desktop with a radeon x600.

- James
Comment 9 eric magaoay 2009-05-18 14:13:39 EDT
James,
I tried your procedure but did not succeed. Here is the result of what happened:
I was able to uncheck "Mirror screens" and bring up both screens, but both monitors are set and fixed to the red square. I moved the "green square to the left of the red square", but as soon as I press the "apply", the mouse icon and keyboard become locked and I think both monitors switched to the green square that doesn't have the menus on both displays. Only hardware reset will bring back the previous setting again.


hardware: ATI Radeon X700 Pro
Comment 10 Bug Zapper 2009-06-09 10:50:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 11 Matěj Cepl 2009-11-05 13:27:52 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 12 Bruce Martin 2010-01-31 02:24:17 EST
Created attachment 387818 [details]
2 Linux bugs saved as pert of my current task list for 2 Fedora 12 installations.

I am a new user, but with a technical background (as much electronics as IT).

I have traaped a number of error texts that were lost in the process of setting up, but do not know how to classify them properly. They were lost from the automatic bug reporter before I got a proper Bugzilla account to send them.

Can someone please help clean up my mess and get this stuff in the right places, please?
Comment 13 Bug Zapper 2010-04-27 10:00:58 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Vedran Miletić 2010-05-24 13:44:32 EDT
Improving summary.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

[This triage is part of collective effort done by students of University of
Rijeka Department of Informatics.]
Comment 15 Bug Zapper 2010-06-28 08:16:38 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.