Bug 498348 - [PATCH] service openvpn start fails because $conf.sh isn't sourced properly
[PATCH] service openvpn start fails because $conf.sh isn't sourced properly
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openvpn (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
: 539448 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-29 20:54 EDT by Alexandre Oliva
Modified: 2010-01-27 20:02 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.1.1-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-13 20:23:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2009-04-29 20:54:09 EDT
Description of problem:
/etc/init.d/openvpn contains:

        for c in `/bin/ls *.conf 2>/dev/null`; do
            bn=${c%%.conf}
            if [ -f "$bn.sh" ]; then
                . $bn.sh                          # this is line 153
            fi

This fails unless root's PATH contains “.”, because bash searches the PATH in order to source pathnames without slashes.

When source fails, openvpn fails to start any configuration for which a .sh file exists.

The fix is trivial: make line 153 “. ./$bn.sh”

Version-Release number of selected component (if applicable):
openvpn-2.1-0.32.rc15.fc11
Comment 1 Bug Zapper 2009-06-09 10:50:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Gwyn Ciesla 2010-01-04 14:03:40 EST
*** Bug 539448 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-01-05 10:26:44 EST
openvpn-2.1.1-2.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/openvpn-2.1.1-2.fc12
Comment 4 Fedora Update System 2010-01-06 20:00:27 EST
openvpn-2.1.1-2.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0249
Comment 5 Fedora Update System 2010-01-13 20:21:19 EST
openvpn-2.1.1-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openvpn'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2010-0504
Comment 6 Fedora Update System 2010-01-13 20:23:09 EST
openvpn-2.1.1-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-01-27 20:02:36 EST
openvpn-2.1.1-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.