Bug 498369 - mount.cifs dies with a segfault if given no arguments
mount.cifs dies with a segfault if given no arguments
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Layton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 01:53 EDT by Penelope Fudd
Modified: 2014-06-18 03:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-20 09:14:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Penelope Fudd 2009-04-30 01:53:02 EDT
Description of problem:
mount.cifs dies with a segfault if run with no arguments

Version-Release number of selected component (if applicable):
samba-client-3.2.11-0.30.fc10.i386

How reproducible:
Always

Steps to Reproduce:
1. /sbin/mount.cifs
2.
3.
  
Actual results:
Segmentation fault

Expected results:
"This program is not intended to be run from the command line, please see 'man mount.cifs'."

Additional info:
Even given the worst input imaginable, a program should never segfault.
Comment 1 Jeff Layton 2009-05-20 09:14:53 EDT
Michael Adam fixed this upstream recently. It should make its way into fedora when samba gets updated to 3.4.

Closing with a resolution of UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.