Bug 49840 - incorrect X configs for Trident Cyberblade / Compaq 12XL125 generated
incorrect X configs for Trident Cyberblade / Compaq 12XL125 generated
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-24 11:02 EDT by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-05 13:39:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
incorrect generated XF86Config (16.33 KB, text/plain)
2001-08-10 18:17 EDT, Chris Ricker
no flags Details
XF86Config from 7.1 (9.68 KB, text/plain)
2001-08-10 18:21 EDT, Chris Ricker
no flags Details

  None (edit)
Description Chris Ricker 2001-07-24 11:02:39 EDT
Text install, updates 07192001 disk

anaconda detects the right video chipset, but then generates totally borked
X configs.  The X 4 config generated only includes resolutions higher than
the LCD supports, and the X 3 config similar includes no valid modes.

anaconda is also still defaulting to X 3 for this chipset, even though X 4
now supports it.
Comment 1 Michael Fulbright 2001-07-24 11:58:22 EDT
Please try again when Beta 3 is out.
Comment 2 Glen Foster 2001-07-24 16:43:02 EDT
This defect is considered MUST-FIX for Fairfax.
Comment 3 Chris Ricker 2001-08-05 10:28:44 EDT
Still true with Beta 3 (GUI install)

both XF86 3 and 4 config files are generated.  neither are correct.  System
defaults to XF86 3.
Comment 4 Michael Fulbright 2001-08-07 10:16:54 EDT
Did you choose the proper monitor type to match your LCD?
Comment 5 Chris Ricker 2001-08-07 10:23:11 EDT
I let it auto-detect, which is what I've done in the past.

My correct LCD type isn't listed....
Comment 6 Michael Fulbright 2001-08-08 23:24:44 EDT
Try using the "Generic Laptop Display Panel 1024x768" (assuming your laptop can
do 1024x768, pick the correct one if not).

What monitor did it autoprobe, btw?
Comment 7 Chris Ricker 2001-08-10 11:37:44 EDT
Here's what it autoprobed:

Section "Monitor"
    Identifier  "Probed Monitor"
    VendorName  "Unknown"
    ModelName   "Unknown"
    HorizSync   46.876
    VertRefresh 75.121
    ModeLine    "800x600" 48.002 800 832 928 1024 600 604 608 624 -HSync -VSync
EndSection
Comment 8 Michael Fulbright 2001-08-10 12:48:54 EDT
Could you attach the working XF86Config(-4?) that you used in 7.1, and also the
config file the installer now creates? I'd like to compare them.
Comment 9 Chris Ricker 2001-08-10 18:17:53 EDT
Created attachment 27353 [details]
incorrect generated XF86Config
Comment 10 Chris Ricker 2001-08-10 18:21:16 EDT
Created attachment 27354 [details]
XF86Config from 7.1
Comment 11 Chris Ricker 2001-08-10 18:31:25 EDT
Sorry if there are three attachments instead of two -- bugzilla is balking again.

XF86Config is the broken config generated by beta3.  It can be fixed simply by
switching SVGA from Probed Monitor to Unprobed Monitor.

XF86Config-7.1 is the config I used on RH 7.1.

I've never gotten an XF86Config-4 that works with that LCD and video card, even
though the chipset is supported by XFree86 4.
Comment 12 Michael Fulbright 2001-08-13 11:58:03 EDT
Did it work when you manually chose "Generic Laptop Display Panel 1024x768"
(assuming your laptop can do 1024x768, pick the correct one if not)?

Could you attach the output from ddcprobe for this machine (its in the anaconda
RPM)?


Comment 13 Chris Ricker 2001-08-13 13:47:17 EDT
It still didn't work.  Here's ddcprobe:

[root@localhost root]# ddcprobe 
VESA 2.0 detected.
OEM Name: Copyright 1998 TRIDENT MICROSYSTEMS INC.
Memory installed = 128 * 64k blocks = 8192kb
Supported standard modes:
        1024x768x16m
        640x480x16m
        800x600x16m
        1024x768x32k
        1024x768x64k
        800x600x32k
        800x600x64k
        640x480x32k
        640x480x64k
        1024x768x256
        640x400x256
        640x480x256
        800x600x256
        1024x768x16
        800x600x16
EDID read failed. (No DDC-capable monitor attached?)
[root@localhost root]# 
Comment 14 Michael Fulbright 2001-08-14 11:31:54 EDT
So to summarize, DDC probing does not work (not surprising, since it isn't
supposed to be able to handle LCDs), and specifying a monitor manually also
creates a bad XF86Config (its putting the wrong monitor section).

Does this sound correct?

Comment 15 Chris Ricker 2001-08-14 11:42:22 EDT
Yep!
Comment 16 Michael Fulbright 2001-08-14 17:34:47 EDT
I've done an install on a machine with a older Neomagic chipset and it failed to
DDD probe the LCD. I picked 'Generic LCD 1024x768" and rebooted. X came up fine.
This was a GUI text case.

When I tried the TUI case - it looks like for my Neomagic it defaulted to 256k
of video RAM, which is not enough.  How much does the card configuration screen
default to for you?
Comment 17 Chris Ricker 2001-08-21 02:50:32 EDT
It defaulted to 8192k for me

I've done a fresh install, text mode, with RC1.  With RC1, it's the same as
beta3.  It detects the right chipset and right amount of memory.  It doesn't
detect the LCD.  When I tell it to use the generic 1024x768 LCD, it generates
broken X configs.
Comment 18 Chris Ricker 2001-09-05 13:39:28 EDT
RC2 works for me, though I still have to force it to use the generic 1024x768
LCD instead of unprobed.  Also, only XFree86 3 works in RC2, even though XFree86
4 supports the chipset.
Comment 19 Michael Fulbright 2001-09-05 17:50:39 EDT
Great glad to hear its finally working. Hopefully we can probe LCDs better in
the future.

Note You need to log in before you can comment on or make changes to this bug.