Bug 498405 - qemu disk image corruption with qcow2/virtio
qemu disk image corruption with qcow2/virtio
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-04-30 06:50 EDT by Mark McLoughlin
Modified: 2009-05-19 20:53 EDT (History)
6 users (show)

See Also:
Fixed In Version: 0.10.4-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-19 20:53:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-04-30 06:50:52 EDT
Booting a guest with a qcow2 image and the virtio block backend, I get filesystem errors and disk corruption e.g.:

  ext4_abort called.
  EXT4-fs error (device dm-0): ext4_journal_start_sb: Detected aborted journal
  Remounting filesystem read-only

I don't get this with raw disk images or the IDE block backend

Command line:
  qemu-kvm -S -M pc -m 1024 -smp 2
           -drive index=0,file=/var/lib/libvirt/images/f11-preview.snap1.qcow2,
                  format=qcow2,if=virtio,boot=on
           -net nic,macaddr=00:16:3e:6c:05:22,model=virtio
           -net tap,ifname=tap0,script=/etc/qemu-ifup
           -nographic -serial telnet::4445,server,nowait -monitor stdio

The disk image was created by installing F11Preview to a raw disk image, converting to qcow2 and then creating a COW image backed by it.

I've also reproduced this with qemu-kvm.git's maint/2.6.30 branch (kvm-84-239-g50cc670)

Tempted to add this to F11VirtBlocker, but since qcow2 isn't often used by Fedora users I'll leave it on F11VirtTarget.
Comment 1 Mark McLoughlin 2009-05-05 09:26:24 EDT
Avi came up with a workaround patch which apparently fixes this:

  http://patchwork.kernel.org/patch/21849/
Comment 2 Fedora Admin XMLRPC Client 2009-05-07 08:12:20 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2009-05-07 08:13:29 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Fedora Admin XMLRPC Client 2009-05-07 08:13:55 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2009-05-07 13:58:17 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Mark McLoughlin 2009-05-11 05:56:03 EDT
This appears to be the final agreed upon fix:

  http://lists.gnu.org/archive/html/qemu-devel/2009-05/msg00378.html
Comment 7 Gleb Natapov 2009-05-11 07:36:29 EDT
*** Bug 500051 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2009-05-13 07:59:03 EDT
qemu-0.10.4-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-2.fc11
Comment 9 Fedora Update System 2009-05-13 11:06:59 EDT
qemu-0.10.4-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-3.fc11
Comment 10 Fedora Update System 2009-05-13 22:56:29 EDT
qemu-0.10.4-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-4954
Comment 11 Fedora Update System 2009-05-14 07:33:42 EDT
qemu-0.10.4-4.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-4.fc11
Comment 12 Fedora Update System 2009-05-15 19:35:35 EDT
qemu-0.10.4-4.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5050
Comment 13 Fedora Update System 2009-05-18 23:37:00 EDT
qemu-0.10.4-5.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.4-5.fc11
Comment 14 Fedora Update System 2009-05-19 20:52:47 EDT
qemu-0.10.4-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.