Bug 498418 - Boolean Query: Enable (time) snap shot based queries
Boolean Query: Enable (time) snap shot based queries
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
3.6
All Linux
low Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 08:22 EDT by Chris Ward
Modified: 2013-06-23 22:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-27 06:23:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ward 2009-04-30 08:22:16 EDT
Description of problem:
For metric gathering purposes, it would be terribly useful if one could query bugzilla based on snapshots in time (day granularity) using standard boolean queries (webui and xmlrpc). For example, i would like to know exactly how many FutureFeatures there were on 2009-01-01 (23:59), which also meet an arbitrary number of other query criteria.

Today it is possible to query bugs which 'changed to FutureFeature' on 2009-01-01. But this doesn't account for bugs the way i would like to, as it only finds the bugs that actually 'changed to', ignore those which were already FutureFeature. IOW I want to know the total number of FutureFeature bugs on 2009-01-01 (at 23:59), irrespective of there state the day before or the day after.

Effectively, this would be equivalent of me 'going back in time' and making the given boolean query request at 23:59 on 2009-01-01.
Comment 1 Chris Ward 2009-04-30 08:27:15 EDT
reported upstream https://bugzilla.mozilla.org/show_bug.cgi?id=477595

Could i get some feedback with regards to the difficultly and feasibility of this request?
Comment 2 David Lawrence 2009-05-01 16:50:52 EDT
I think the Series Charts are supposed to be address this but it is not exported through any other interface except for the web UI. For information on series charts see:

http://www.bugzilla.org/docs/tip/en/html/reporting.html 

As for the query.cgi UI, mostly works off current state of bugs in the database since it directly converts the criteria to SQL. The bugs changes section of query.cgi is accessing the activity table but as you mentioned it only looks for activity entries that occurred in a date range so it missed any bug hits that were already in the state you are looking for before the range you specify.

I am not sure what upstream will say regarding this.

Dave
Comment 3 Chris Ward 2009-05-04 03:28:27 EDT
Yea, looks like the reporting might help me map the data i want. However, I would still prefer the flexibility of being able to query the data using xmlrpc, to map it using my own implemented plot system. Do you think such a feature would be difficult to implement? Upstream has so far given me no response.

I envision being about to query bugzilla exactly the same way i do today, using boolean queries, but there being an additional field called 'on_day', which accepts a past date.
Comment 4 David Lawrence 2010-01-15 12:32:26 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 5 David Lawrence 2010-08-25 17:42:47 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 6 Chris Ward 2010-08-27 06:23:18 EDT
i'm working an outside of bugzilla solution to this as we speak. Closing.

Note You need to log in before you can comment on or make changes to this bug.