Bug 498419 - SELinux is preventing accton (acct_t) "read" to inotify (inotifyfs_t).
SELinux is preventing accton (acct_t) "read" to inotify (inotifyfs_t).
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: cronie (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 08:31 EDT by Petr Lautrbach
Modified: 2009-05-25 17:22 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.2-8.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-06 09:17:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Lautrbach 2009-04-30 08:31:36 EDT
Description of problem:
SELinux denied access requested by accton. It is not expected that this access is required by accton and this access may signal an intrusion attempt. It is also possible that the specific version or configuration of the application is causing it to require additional access. 

Version-Release number of selected component (if applicable):
selinux-policy-3.5.13-57.fc10.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Source Context:  system_u:system_r:acct_t:s0-s0:c0.c1023
Target Context:  system_u:object_r:inotifyfs_t:s0Target 
Objects:  inotify [ dir ]
Source:  accton
Source Path:  /sbin/accton
Port:  <Unknown>
Source RPM Packages:  psacct-6.3.2-51.fc10 
Policy RPM:  selinux-policy-3.5.13-57.fc10
Selinux Enabled:  True
Policy Type:  targeted
MLS Enabled:  True
Enforcing Mode:  Permissive
Plugin Name:  catchall_file

Raw Audit Messages :

node=2x4b-523p.englab.brq.redhat.com type=AVC msg=audit(1241057292.115:5049): avc: denied { read } for pid=13366 comm="accton" path="inotify" dev=inotifyfs ino=1 scontext=system_u:system_r:acct_t:s0-s0:c0.c1023 tcontext=system_u:object_r:inotifyfs_t:s0 tclass=dir node=2x4b-523p.englab.brq.redhat.com type=SYSCALL msg=audit(1241057292.115:5049): arch=c000003e syscall=59 success=yes exit=0 a0=131f100 a1=131e5c0 a2=131e210 a3=8 items=0 ppid=13355 pid=13366 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=589 comm="accton" exe="/sbin/accton" subj=system_u:system_r:acct_t:s0-s0:c0.c1023 key=(null) 

Expected results:


Additional info:
Comment 1 Daniel Walsh 2009-04-30 08:39:40 EDT
Is accton run out of cron?
Comment 2 Petr Lautrbach 2009-04-30 09:14:01 EDT
It looks like cron.daily runs /etc/cron.daily/logrotate that runs /etc/logrotate.d/psacct with command /usr/sbin/accton /var/account/pacct
Comment 3 Daniel Walsh 2009-04-30 09:54:09 EDT
Cron is leaking an open file descriptor to inotifyfs which is causing this problem.

Reassigning.

You can ignore the error for now.
Comment 4 Marcela Mašláňová 2009-05-04 06:07:44 EDT
Should be fixed in rawhide. Please test the update cronie-1.2-8.fc10
Comment 5 Fedora Update System 2009-05-04 06:15:52 EDT
cronie-1.2-8.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/cronie-1.2-8.fc10
Comment 6 Fedora Update System 2009-05-25 17:22:54 EDT
cronie-1.2-8.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.