Bug 49842 - pcmcia network interface doesn't start
Summary: pcmcia network interface doesn't start
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-24 15:08 UTC by Chris Ricker
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 19:01:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-07-24 15:08:46 UTC
Currently, the network init scripts are run before the scripts which load
support for pcmcia devices.  This needs to be re-ordered so that networking
with pcmcia NICs will cleanly start up on laptops; the current ordering
results in lots of error messages, kudzu starting up and complaining about
missing devices on every single bootup, etc.

The problem is compounded by the bug in text-based installs in which it's
impossible to configure NICs not to attempt to load automatically at boot....

Comment 1 Bill Nottingham 2001-07-24 15:47:23 UTC
Please see the twenty-five other times this has been reported.

PCMCIA cardbus interfaces should be set up as ONBOOT=no.
This causes no messages to be sent. They will then be brought up by the PCMCIA
package.


Comment 2 Chris Ricker 2001-07-24 15:54:54 UTC
See bug # 49779

Either init scripts need to be re-ordered, or the text installer needs to be
fixed to correctly configure pcmcia devices.

Comment 3 Chris Ricker 2001-07-25 13:53:44 UTC
ONBOOT=no

I'm *still* getting lots of spewage, kudzu complaining, etc.

Comment 4 Chris Ricker 2001-07-26 17:19:41 UTC
The other issue, of course, is that I actually *do* want my NIC enabled at boot.
 If I use ONBOOT=no, I get error messages and no NIC enabled (I have to manually
run ifup eth0 to get the DHCP lease).  If I use ONBOOT=yes, I get error messages.

This is regression from 7.1, in which I had error-less DHCP configuration of my
CardBus NIC at boot-time.

Comment 5 Chris Ricker 2001-08-05 14:32:44 UTC
Still true with beta 3, still major regression from 7.1

Comment 6 Bill Nottingham 2001-08-05 21:14:33 UTC
the script ordering is irrelevant. something else is wrong.

Remove the check_link_down call from ifup (or install 6.11-1) - does that
help?

Comment 7 Chris Ricker 2001-08-06 18:35:50 UTC
Ignore the re-ordering suggestion; it was just my stab in the dark at an attempt
to fix the problem.

Here's what I see with stock beta3:

ONBOOT=yes:  kudzu yells during boot, card is initialized but doesn't get a dhcp
lease
ONBOOT=no:  kudzu yells during boot, card is initialized but doesn't get a dhcp
lease

with the if check_link_down block commented out and beta 3:

ONBOOT=yes:  kudzu yells during boot, card gets a dhcp lease automatically
ONBOOT=no:  kudzu yells during boot, card gets a dhcp lease automatically

So, basically ONBOOT= seems to be ignored.  kudzu always complains (because it's
trying to load tulip.o before loading cardbus support?), and automatic
configuration of the card on bootup is broken with the stock ifup script.

I'm going to now blow away the card entirely and see if it'll then work when I
reconfigure it.

Comment 8 Chris Ricker 2001-08-06 19:01:24 UTC
Okay, latest results.  I removed the card entirely from the kudzu database. 
After that, with the stock beta3 ifup, I get no automatic dhcp lease on the card
on bootup.  With the modified ifup, I get

ONBOOT=yes:  error message after configuring lo0, but then card gets dhcp lease
automatically anyway
ONBOOT=no:  no error messages, card automatically gets an IP lease.

So, it looks like with the new ifup, ONBOOT=no will do the right thing.  One bug
still exists, however.  A bogus entry is being created in the kudzu database
during install (pcmcia devices get dumped into kudzu by anaconda, I guess, but
shouldn't be there because kudzu gets run before pcmcia support gets loaded). 
I'm not sure if that's a bug in kudzu, init scripts, or anaconda....

Comment 9 Bill Nottingham 2001-08-07 05:27:56 UTC
kudzu message squashed in 0.99.12-1. That's been broken for way too long. :(

Other stuff should be taken care of with initscripts-6.12-1.


Note You need to log in before you can comment on or make changes to this bug.