Bug 498441 - Removing a package from the a channel in the UI doesn't update repo cache
Removing a package from the a channel in the UI doesn't update repo cache
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.5
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
Jeff Ortel
:
Depends On:
Blocks: space06 498506
  Show dependency treegraph
 
Reported: 2009-04-30 10:20 EDT by Justin Sherrill
Modified: 2009-09-10 08:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 498506 (view as bug list)
Environment:
Last Closed: 2009-09-10 08:06:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-04-30 10:20:47 EDT
When you remove a package from a channel, the new repocache mechanism is never signalled to regenerate the yum cache.  

We should probably add this in ChannelManager.refreshWithNewestPackages() so we cover anytime the newest packages are refreshed to get other cases where we're forgetting to initiate a cache rebuild
Comment 1 Justin Sherrill 2009-04-30 15:29:08 EDT
579fffa - added call to  ChannelManager.queueChannelChange() within refreshWithNewestPackages(), so we should over everything we need to.
Comment 2 Jeff Ortel 2009-07-07 16:04:47 EDT
Verified as follows:
1) Registered system to empty custom child channel of EL5 channel.
2) Ran "yum list available | grep suds" on system and observed python-suds package not listed.
3) Added python-suds package to channel.
4) After a few minutes, re-ran step #2 and observed python-suds listed in channel.
5) Removed python-suds package from channel.
6) After a few minutes, re-ran step #2 and observed python-suds *not* listed in channel. 

repomd seems to be re-generated when package added or removed from a channel.
Comment 3 Miroslav Suchý 2009-09-10 08:06:05 EDT
Spacewalk 0.6 released

Note You need to log in before you can comment on or make changes to this bug.