This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 498456 - HTTPS feed URLs broken in planet-2.0-3.el5
HTTPS feed URLs broken in planet-2.0-3.el5
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: planet (Show other bugs)
el5
All Linux
low Severity high
: ---
: ---
Assigned To: Jon Ciesla
Fedora Extras Quality Assurance
ActualBug
:
Depends On:
Blocks: 1181144
  Show dependency treegraph
 
Reported: 2009-04-30 11:24 EDT by Jim Schneider
Modified: 2015-01-28 16:44 EST (History)
4 users (show)

See Also:
Fixed In Version: planet-2.0-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 18:02:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jim Schneider 2009-04-30 11:24:09 EDT
Description of problem:
Attempting to read a feed from an HTTPS URL logs an error message of "Error 500 while updating feed".  A debugging print statement added to /usr/lib/python2.4/site_package/planet/__init__.py to see the actual exception being returned from the feed parser gave the error message:

 ssl() argument 1 must be _socket.socket, not _socketobject

Googling for that exact phrase provided this link: http://mail.python.org/pipermail/python-list/2005-May/323170.html

The article at this link explains that the culprit is the timeoutsocket library.  Removing the files matching /usr/lib/python2.4/site_package/planet/timeoutsocket.py* fixed the problem.

Version-Release number of selected component (if applicable):
2.0-3.el5

How reproducible:
Always

Steps to Reproduce:
1. Configure planet to aggregate a feed from an HTTPS source.
  
Actual results:
Fails to connect with a type mismatch exception.

Expected results:
Reads the feed (or fails to connect for some other reason).
Comment 1 Jim Schneider 2009-04-30 11:33:20 EDT
Looks like I relied on memory, when I should have relied on cut and paste.  The path "/usr/lib/python2.4/site_package/planet" should be "/usr/lib/python2.4/site-packages/planet".  I apologize for the confusion.
Comment 2 Richard Dawe 2009-05-08 16:55:39 EDT
Thanks for reporting the bug.

Unfortunately I'm not going to be able to look at this bug for at least 2 weeks.
Comment 3 Richard Dawe 2009-05-30 14:07:19 EDT
Blog page on this subject, with similar suggestions:

http://www.theospears.com/blog/2008/12/25/planet-and-https-feeds/
Comment 4 Richard Dawe 2009-06-06 08:57:54 EDT
Please note that I've just orphaned this package. There's hopefully someone lined up who is interested in maintaining it, and fixing this issue.
Comment 6 Jon Ciesla 2013-08-30 13:47:42 EDT
Both links in this BZ are 404, can you still reproduce this?
Comment 7 Alexander Koenig 2015-01-11 06:19:18 EST
HTTPS feeds are still broken with planet-2.0-19.fc21.noarch (fails on https://terminatorX.org/feed/ with our local installation). The problem is that 'timeoutsocket.py' is no longer compatible with current python sockets, however as the timeout feature is not even being used by planet it is safe to just remove timeoutsocket.py from the sources and HTTPS feeds work without problems again.
Comment 8 Jon Ciesla 2015-01-12 11:27:35 EST
Please test the rawhide build.  If it's good I'll build it everywhere.

http://koji.fedoraproject.org/koji/buildinfo?buildID=603510
Comment 9 Alexander Koenig 2015-01-12 15:04:01 EST
Excellent, package installs without issues and planet handles http and https feeds without issues again (checked with cleared caches, too). Thanks!
Comment 10 Jon Ciesla 2015-01-12 15:06:23 EST
Excellent, thanks!  Updates on their way.
Comment 11 Fedora Update System 2015-01-12 15:20:30 EST
planet-2.0-20.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/planet-2.0-20.el5
Comment 12 Fedora Update System 2015-01-12 15:20:40 EST
planet-2.0-20.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/planet-2.0-20.el6
Comment 13 Fedora Update System 2015-01-12 15:20:51 EST
planet-2.0-20.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/planet-2.0-20.fc20
Comment 14 Fedora Update System 2015-01-12 15:22:06 EST
planet-2.0-20.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/planet-2.0-20.el7
Comment 15 Fedora Update System 2015-01-12 15:22:20 EST
planet-2.0-20.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/planet-2.0-20.fc21
Comment 16 Fedora Update System 2015-01-13 17:08:15 EST
Package planet-2.0-20.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing planet-2.0-20.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2015-0236/planet-2.0-20.el7
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2015-01-21 18:02:22 EST
planet-2.0-20.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2015-01-21 18:06:01 EST
planet-2.0-20.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2015-01-28 16:38:17 EST
planet-2.0-20.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Fedora Update System 2015-01-28 16:43:54 EST
planet-2.0-20.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2015-01-28 16:44:44 EST
planet-2.0-20.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.