Bug 498480 - [RHEL4.6] bonding mode=802.3ad always boot with first slave down
[RHEL4.6] bonding mode=802.3ad always boot with first slave down
Status: CLOSED DUPLICATE of bug 432622
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.6
All Linux
high Severity high
: rc
: ---
Assigned To: Jiri Pirko
Red Hat Kernel QE team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-30 13:01 EDT by Flavio Leitner
Modified: 2015-05-04 21:16 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-05 15:05:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of bonding with debug enabled (121.06 KB, text/plain)
2009-04-30 13:02 EDT, Flavio Leitner
no flags Details
patch fixing link partner (1.27 KB, patch)
2009-04-30 13:08 EDT, Flavio Leitner
no flags Details | Diff

  None (edit)
Description Flavio Leitner 2009-04-30 13:01:14 EDT
After a normal boot, the system always comes up with first slave down.
If you manually set slave iface up by doing 'ip link set dev up' it comes 
back online. If you restart the network service the problem reproduces 
and if you de-enslave eth0 (ifenslave -d bond0 eth0), eth1 goes down.

Module options:
install bond0 /sbin/modprobe bonding -o bond0 miimon=500 mode=4 lacp_rate=fast xmit_hash_policy=layer3+4 use_carrier=0

Changing use_carrier=1 (default) didn't help.
There is a log with debug output enabled from bonding driver but I couldn't
see anything odd there.

The message logs shows the interface detected, then enslaved, link up and
finally link down.

Additional info:
"I have the same configuration in a DL580 server where I don't have an issue.
Also I don't have an issue with the BL680c (Full height blades) in the same
enclosure. Only the half height blades (BL460c) in the enclosure have the
issue. Both BL680c and BL460c share the same switches in the enclosure."
Comment 1 Flavio Leitner 2009-04-30 13:02:30 EDT
Created attachment 341962 [details]
log of bonding with debug  enabled
Comment 4 Flavio Leitner 2009-04-30 13:08:50 EDT
Created attachment 341965 [details]
patch fixing link partner

This patch was applied when bonding driver debug output was taken but 
it didn't help.
Comment 7 Jiri Pirko 2009-05-11 10:11:14 EDT
Marking this as a duplicate. This issue is resolved in RHEL4.7.

*** This bug has been marked as a duplicate of bug 437865 ***
Comment 10 Jiri Pirko 2009-05-12 10:19:33 EDT
Can you please provide additional info?

What machine does this issue occur at? Only BL460c? Do we have one suitable for internal testing?
Does this issue occur also with RHEL5 and upstream kernel?
Comment 11 Jiri Pirko 2009-05-12 10:28:19 EDT
I want to also ask what appears on the output of "mii-tool" command and "ethtool eth2" after line "Mar 18 16:56:22 pmtraams02 kernel: bonding: bond0: link status definitely down for interface eth2, disabling it".

Thanks
Comment 12 Jiri Pirko 2009-05-13 14:00:08 EDT
I tried to reproduce the problem on the only machine we have in rhts: hp-bl460c-02.rhts.bos.redhat.com. No luck :/
Comment 24 Paul Batkowski 2009-11-05 15:05:13 EST
Closing as a dup of bz#432622

*** This bug has been marked as a duplicate of bug 432622 ***

Note You need to log in before you can comment on or make changes to this bug.